2

Whenever I want to start a second X-Server (one is running on display :0, I started the second with X :1, as root, but as normal user it doesn't work either) it won't start. The relevant error message seems to be (EE) intel(0): [drm] failed to set drm interface version: Permission denied [13]. and (EE) intel(0): Failed to claim DRM device. (the (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied is there also for the successfully running Xorg on display :0).

Does anyone know a way to start a second Xserver?

I am using intel driver, kernel-side it is i915 with modesetting.

The relevant Xorg.log is attached.

[  6646.990] 
X.Org X Server 1.17.2
Release Date: 2015-06-16
[  6646.996] X Protocol Version 11, Revision 0
[  6646.998] Build Operating System: Linux 4.0.4-2-ARCH x86_64 
[  6647.004] Current Operating System: Linux felics-tablet 3.18.21-ck-bfs-tuxice-uksm-bfq-gccopt-phcintel #6 PREEMPT Tue Sep 15 20:07:15 CEST 2015 x86_64
[  6647.005] Kernel command line: root=/dev/sda5 ro kdb=off loglevel=9 pcie_aspm=force slub_debug=- vt.default_utf8=1 fbcon=font:VGA8x8 acpi_backlight=vendor intel_iommu=off vga=6 resume=/dev/sda9
[  6647.012] Build Date: 30 June 2015  09:00:12PM
[  6647.014]  
[  6647.016] Current version of pixman: 0.32.6
[  6647.021]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[  6647.021] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  6647.032] (==) Log file: "/var/log/Xorg.1.log", Time: Thu Sep 17 11:41:35 2015
[  6647.035] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  6647.037] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  6647.038] (==) No Layout section.  Using the first Screen section.
[  6647.038] (==) No screen section available. Using defaults.
[  6647.038] (**) |-->Screen "Default Screen Section" (0)
[  6647.038] (**) |   |-->Monitor ""
[  6647.039] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
[  6647.039] (**) |   |-->Device "Device0"
[  6647.039] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[  6647.039] (**) Option "AutoAddDevices" "true"
[  6647.039] (**) Automatically adding devices
[  6647.039] (==) Automatically enabling devices
[  6647.039] (==) Automatically adding GPU devices
[  6647.039] (**) FontPath set to:
    /usr/share/fonts/local/,
    /usr/share/fonts/misc/,
    /usr/share/fonts/TTF/,
    /usr/share/fonts/OTF/,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi/,
    /usr/share/fonts/75dpi/
[  6647.039] (==) ModulePath set to "/usr/lib/xorg/modules"
[  6647.039] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[  6647.039] (II) Loader magic: 0x816d60
[  6647.039] (II) Module ABI versions:
[  6647.039]    X.Org ANSI C Emulation: 0.4
[  6647.039]    X.Org Video Driver: 19.0
[  6647.039]    X.Org XInput driver : 21.1
[  6647.039]    X.Org Server Extension : 9.0
[  6647.042] (EE) systemd-logind: failed to get session: The name org.freedesktop.login1 was not provided by any .service files
[  6647.043] (II) xfree86: Adding drm device (/dev/dri/card0)
[  6647.043] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[  6647.480] (--) PCI:*(0:0:2:0) 8086:2a42:17aa:20e4 rev 7, Mem @ 0xf2000000/4194304, 0xd0000000/268435456, I/O @ 0x00001800/8
[  6647.481] (--) PCI: (0:0:2:1) 8086:2a43:17aa:20e4 rev 7, Mem @ 0xf2400000/1048576
[  6647.481] (II) Open ACPI successful (/var/run/acpid.socket)
[  6647.481] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[  6647.481] (II) LoadModule: "dri"
[  6647.481] (II) Module "dri" already built-in
[  6647.481] (II) LoadModule: "glx"
[  6647.482] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  6647.485] (II) Module glx: vendor="X.Org Foundation"
[  6647.486]    compiled for 1.17.2, module version = 1.0.0
[  6647.486]    ABI class: X.Org Server Extension, version 9.0
[  6647.486] (==) AIGLX enabled
[  6647.486] (II) LoadModule: "extmod"
[  6647.486] (II) Module "extmod" already built-in
[  6647.486] (II) LoadModule: "intel"
[  6647.486] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[  6647.486] (II) Module intel: vendor="X.Org Foundation"
[  6647.486]    compiled for 1.17.2, module version = 2.99.917
[  6647.486]    Module class: X.Org Video Driver
[  6647.486]    ABI class: X.Org Video Driver, version 19.0
[  6647.486] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[  6647.487] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[  6647.487] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[  6647.487] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[  6647.487] (--) using VT number 14

[  6647.499] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20140905
[  6647.499] (II) intel(0): SNA compiled from 2.99.917-364-gb24e758
[  6647.500] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[  6649.679] (EE) intel(0): [drm] failed to set drm interface version: Permission denied [13].
[  6649.679] (II) intel(0): [drm] Contents of '/sys/kernel/debug/dri/0/clients':
[  6649.679] (II) intel(0): [drm]              command   pid dev master a   uid      magic
[  6649.679] (II) intel(0): [drm]                 Xorg 16216   0   y    y  1001          0
[  6649.679] (II) intel(0): [drm]        fuzzy-windows 16243   0   n    y  1001         10
[  6649.679] (II) intel(0): [drm]                 Xorg 17590   0   n    y     0          0
[  6649.679] (EE) intel(0): Failed to claim DRM device.
[  6649.679] (II) UnloadModule: "intel"
[  6649.679] (EE) Screen(s) found, but none have a usable configuration.
[  6649.679] (EE) 
Fatal server error:
[  6649.679] (EE) no screens found(EE) 
[  6649.679] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[  6649.680] (EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[  6649.680] (EE) 
[  6649.697] (EE) Server terminated with error (1). Closing log file.
  • i did something like this long ago. but it was 3 X servers. i vaguely remember a few settings each needed. i started them all from init scripts (so they started from root). and it was an older version. i have no need to do it today (it was done as an easy means to switch limited video modes). – Skaperen Sep 17 '15 at 9:57
0

... And the solution is the following:

The other X servers need to run with a different driver. fbdev works. Before starting the second server, edit the Xorg config file (or automate things by re-soft-linking config files and starting up X with one command) to use the fbdev video driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.