5

In my cssh config file, I have:

terminal_font=6x13

this default font is too small for me.

man cssh says, I can specify other font size with the -f argument, while using "standard X font notation". Here is a wikipedia page containing some other fonts types. Unfortunately, none of these work for me:

$ cssh host1 host2 -f "7x14"
Fatal: Unrecognised font used (7x14).
Please amend $HOME/.clusterssh/config with a valid font (see man page).

Why does "7x14" not work? How can I use bigger fonts with cssh ?

1

4 Answers 4

5
+100

I have figured out how to use any font in xterm. So for the case of the mentioned Inconsolata font size 14, the following works:

1) Add these 2 lines into ~/.Xresources (create it if it does not exist)

XTerm*faceName: Inconsolata
XTerm*faceSize: 14

2) Then, tell xterm to use this file:

export XENVIRONMENT="${HOME}/.Xresources"

Preferably add this export into .bashrc, so that it is persistent.

3) comment out the font settings in ~/.clusterssh/config, if it exists:

# terminal_font=6x13
4
+100

You need to set Font Path to a directory containing "7x14" fonts. Check out your current Font Path as:

xset q | grep "Font Path:" -A1

In the output directory list, you need to have mentioned font at least in one directory.

You can add Font Path either dynamically by xset or statically by modifying xorg configuration file.

Use command: xset +fp desired_font_path Or in your xorg configuration file, add FontPath desired_font_path in "Files" section

2

I had the same problem because I have a HiDPI display. The larger font I have in my system (Arch) is 12x24, although I actually use 10x20 because it look better:

cssh -f 10x20 ...

Found them by looking in /usr/share/fonts/misc/font.alias. As per this, font.alias are files that map human friendly stuff like 10x20 to computer friendly stuff like -misc-fixed-medium-r-normal--20-200-75-75-c-100-iso8859-1.

Get the list of the font directories with the xset q command and the look for font.alias inside those dirs. Pick an alias that suits you.

1

The largest bitmap font available via ~/.clusterssh/config is 10x20. On my 4k display I got a decent setting via:

terminal_args=-fa "DejaVu Sans Mono" -fs 14
terminal_size=253x100

ClusterSSH does not pass terminal_size as -geometry. 253x100 translated on my screen into 80 columns, ca. 30 lines.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.