0

I added a new user to one of our servers, but can't log in to it via putty. The error message is "Server refused our key", and from putty, "Disconnected: no supported authentication methods available (server sent: public key). Putty is set up to use a putty private key (.ppk file) to access the server. I looked in /etc/ssh/sshd_config, but didn't find anything specifying the user. Any ideas?

  • 1
    When you created the key, did you append the public key into the authorized_keys file? – ryekayo Sep 15 '15 at 14:18
  • I didn't create the key, it was created by someone who's no longer here. I checked and there is no "authorized_key" file set up in /etc/ssh. Ideally, I'd want to add a new user, give it access using the existing key, then delete or disable the old user. – Jack BeNimble Sep 15 '15 at 19:11
  • 1
    If i were you, i would delete the key and create a new one. You don't know if the person that is no longer "here" still has the private key.. – ryekayo Sep 15 '15 at 19:12
  • 1
    Unless you or "someone" changed the configuration, authorized_keys is in subdirectory .ssh in the home directory of the userid being logged-in. Like many ssh files, it must have permissions set to limit access (usually rw------- or rwx------) or it won't be used. Remember anything beginning with . is omitted by default in ls or echo * or such, so don't be confused by that. – dave_thompson_085 Sep 15 '15 at 20:50
  • @ryekayo - I'm trying to avoid that. The servers are on Amazon and I think I have to recreate the servers to do it. – Jack BeNimble Sep 16 '15 at 2:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.