1

I am trying to use two opencv versions on my computer and I am trying to tell my system to use the most recent one that I compiled and installed locally.

I included the install folder in LD_LIBRARY_PATH and now want to check in which order my system can find opencv 2.4.8 (installed from apt-get) and opencv 3.0 (compiled). Is there a command for that?

1

To check which library the app is using use ldd

ldd /path/to/application

also read up on ldconfig.

1
  • Python does barely use other libraries when started, but it can load python bindings for Opencv for example at runtime. I need to know why it is still loading the older version. – Mehdi Sep 16 '15 at 8:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.