3

I've installed openLDAP on my FreeBSD machine. When I try to run the service, I get the following error.

Unrecognized database type (mdb)

Can someone point me towards what could be wrong?

3
  • 1
    Did you use the package or the port? If you used the port, was the MDB option enabled?
    – user90883
    Sep 14, 2015 at 20:49
  • @ThomasWeinbrenner I used ports. I am guessing that the MDB option is not enabled by default. I do not remember being prompted to enable this during the installation process Sep 14, 2015 at 21:03
  • 2
    According to this it is a default option. Try to enable it and build the port again.
    – user90883
    Sep 14, 2015 at 21:20

1 Answer 1

0

I had the same thing. There're some options in the slapd.conf file which are commented out. Look for:

# Load dynamic backend modules:
modulepath      /usr/local/libexec/openldap
# moduleload    back_mdb
# moduleload    back_ldap

Uncomment the back_mdb line and that should sort it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .