1

I'm currently running a Xubuntu image using VirtualBox and a strange issue just started occurring: I cannot enter a or c in a terminal or terminal emulator. A and C (that is, a/c + left/right Shift or with Caps Lock active) work just fine, and a/c work fine in graphical applications; it's only when using the full terminal or xfce4-terminal/xterm that the keys don't work. This seems to be a user-specific thing, as I can use a and c just fine when entering the user name for login at a terminal but once logged in the keys no longer work; however, I cannot figure out what settings I changed to somehow cause it.

Additional info: the characters are also filtered when pasting text into a terminal emulator; for a moment, I was able to get a to paste as part of a string when it was at the front, but I'm no longer able to.

  • What shell are you using? – jimmij Sep 13 '15 at 22:31
  • @jimmij GNU bash, version 4.3.30(1)-release (x86_64-pc-linux-gnu) – JAB Sep 13 '15 at 22:33
  • If you run tee in that terminal, can you type a and c? – Gilles Sep 13 '15 at 22:40
  • @Gilles Yes, and I can also paste them in. This also works if I run a terminal program such as vim, etc.; it seems to be limited to the command line/shell itself. – JAB Sep 13 '15 at 22:41
  • Start bash with options --noprofile --norc, same result? – jimmij Sep 13 '15 at 22:48
4

Since this problem occurs on different terminal types, and occurs at a command prompt but not when some other program is reading from the terminal, this is a configuration problem in your shell. You've accidentally defined bindings for a and c.

Assuming that your shell is bash (the default interactive shell on Ubuntu), check the two relevant configuration files in your home directory:

  • .inputrc, the configuration file for the readline library, which bash uses. Look for a line starting with a and a line starting with c.
  • .bashrc, the configuration file for bash when it runs interactively. Look for a line containing bind a… and a line containing bind c….
  • There aren't any lines like that in either .bashrc or .inputrc. – JAB Sep 13 '15 at 22:58
  • Ah, but it was an .inputrc issue after all. I forgot to put set before some variable assignments. Silly me. – JAB Sep 13 '15 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.