2

I just installed Fedora 22 alongside Windows 10 on my desktop and I've been trying to get the Ethernet to work for a long time. There is no wireless and this is my only source of internet connection on linux.

I have a Intel Gigabit Ethernet - "Intel(R) Ethernet Connection (2) I218-V" on my motherboard. I don't believe it is a driver issue.

I'll post the output of some commands here:

[nikhil@nikhil ~]$ dmesg | grep eth
[    1.060111] e1000e 0000:00:19.0 eth0: registered PHC clock
[    1.060114] e1000e 0000:00:19.0 eth0: (PCI Express:2.5GT/s:Width x1) d0:50:99:66:37:81
[    1.060115] e1000e 0000:00:19.0 eth0: Intel(R) PRO/1000 Network Connection
[    1.060152] e1000e 0000:00:19.0 eth0: MAC: 11, PHY: 12, PBA No: FFFFFF-0FF
[    1.060680] e1000e 0000:00:19.0 enp0s25: renamed from eth0    

[root@nikhil nikhil]# ifconfig
enp0s25: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::d250:99ff:fe66:3781  prefixlen 64  scopeid 0x20<link>
        ether d0:50:99:66:37:81  txqueuelen 1000  (Ethernet)
        RX packets 115  bytes 11437 (11.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 245  bytes 32940 (32.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 20  memory 0xf7c00000-f7c20000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 157  bytes 14355 (14.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 157  bytes 14355 (14.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


[root@nikhil nikhil]# vi /etc/sysconfig/network-scripts/ifcfg-enp0s25
HWADDR="D0:50:99:66:37:81"
TYPE="Ethernet"
BOOTPROTO=dhcp
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="yes"
IPV6_AUTOCONF="yes"
IPV6_DEFROUTE="yes"
IPV6_FAILURE_FATAL="no"
NAME="enp0s25"
UUID="7c57db7e-4bb3-473e-9dd6-ee548033bef8"
ONBOOT="yes"
PEERDNS=yes
PEERROUTES=no
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes

Running the command dhclient enp0s25 seems to just hang with no output. Any help would be appreciated.

  • Can you run journalctl -b -p3 and look for errors that might be relevant? – mattdm Sep 14 '15 at 15:32
1

I'm not sure the symptoms of your problem are the same, but I had some similar issues with dual booting recently. Is your network connection fine in Windows?

I had issues where I would install Linux, network would be fine, then would reboot into Windows, network would be fine, then reboot into Linux, eth0 wouldn't connect. Turns out that Windows sets some wake on LAN properties of the Intel 1218-V network connection that confuses the e1000e module. I fixed my problem by disabling all the wake on LAN options for the network connection from within the driver properties dialog in Windows.

Good luck!

From here:

https://bbs.archlinux.org/viewtopic.php?id=191981

  • This seems to represent the root cause; thank you. – iokevins Dec 15 '15 at 2:28
  • Hi!! I have the same problem as you said. If I will fresh install the Ubuntu without duel boot , will be the problem gone ? – Muztaba Hasanat Feb 8 '18 at 22:06
2

Are you using Fedora as VM or as dual boot machine ? If you are using as VM, make sure the Ethernet option is on Bridge mode or NAT mode

Have you tried using static IP?

To put static IP

open file : vi /etc/sysconfig/network-scripts/ifcfg-enp0s25
#add following lines to your files 
BOOTPROTO=static (change dhcp to static)
DEVICE=enp0s25 (your interface name)
#Depend on your subnet, put the correct ip.
IPADDR=192.168.1.50
NETMASK=255.255.255.0
BROADCAST=192.168.1.255
NETWORK=192.168.1.0
GATEWAY=192.168.1.1

Restart the network interface.

Once that done, try to ping default gateway. If that's work, you may have DHCP server issue or dhcp client issue. If that's does not work, make sure the physical connection correct. As well as, try to using Windows and see if you get the connection or not.

  • Note: This represents a workaround, as with OP's currently accepted answer. Please see Josh's answer, for what most likely represents the root cause: a NIC wake-on-LAN issue. Thanks. – iokevins Dec 29 '15 at 14:29
0

I managed to solve it by using a static IP. Somehow the DHCP wasn't working. I did not receive any DHCPOFFERS for DHCPREQUESTS sent out by my PC.

  • Note: This represents a workaround; if willing, please try Josh's answer and mark as correct, if so. Thanks. – iokevins Dec 29 '15 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.