2

Possible duplicate: "My Wifi drops the connection after a few minutes realtek8723be" which indicated this problem is a known bug

My wireless stops working randomly when I'm using my laptop. Sometimes it stops working within a few minutes of booting. Other times it works for hours and then stops working.

To be able to use the wireless again, I have to currently reboot my laptop. Is there a way I can make my wireless more persistent?

I'm running Debian GNU/Linux 8 (jessie), and my wireless problems also occurred when trying Ubuntu and Linux Mint (Debian version) also, but works fine with Windows 7. When installing my current Debian distribution, I did recieve the message:

Some of your hardware needs non-free firmware files to operate.
The missing firmware files are: rtlwifi/rtl8723befw.bin

So I found this file in the firmware-realtek package, and downloaded this and installed the .deb file via the "GDebi Package Installer".

I've never debugged wireless/hardware issues before, so any help is greatly appreciated. I have noticed when I run lspci a Unassigned class with respect Realtek:

03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5287 (rev 01)
3

After lots of Googling, I found a recent post with new firmware.

  1. Download rtl8723befw.bin, copy it to /lib/firmware/rtlwifi/ and then reboot your laptop.
  2. Disable the sleep feature of the driver:

    $ echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

    (I also found information using options rtl8723be fwlps=N ips=N, which disables the ips option, but I did not find it necessary to use this)

I also read in many posts that bluetooth can disrupt the WiFi connection, so I permanently disabled it also: $ sudo rfkill block bluetooth $ sudo update-rc.d bluetooth disable (and check it's turned off with sudo service bluetooth status)

[If you find you are still having problems with WiFi suddenly breaking, as peterh mentioned in their answer (big thanks for this), you can reload the relevant module with sudo rmmod rtl8723be && sudo modprobe rtl8723be]

  • Having used my laptop for the majority of today, I have had no WiFi failures requiring a reboot or reloading of the module. I did have one or two periods where my WiFi was not particularly fast, but it looks as though they have found the issue and are working on it – andyandy Sep 13 '15 at 22:47
  • I tried your solution on fresh debian 9 but did not worked... I can not even see any network... These drivers doesn't work for linux... We have to avoid realtek (we who use linux) or the company has to be more friendly with us – koleygr Jun 23 '17 at 22:21
2

It probably won't solve your problem (without the firmware, it is unlikely that your driver will work), but anyways it is very useful if you get the file.

Finding debian packages of files can be done very easily with the apt-file command. Install it (apt-get install apt-file), initialize its package cache (apt-file update), any finally look for the file you want (apt-file search rtlwifi/rtl8723befw.bin). The resul will be the name of the package in which your firmware exists.

In this case, the result is firmware-realtek, but it would be highly useful if you would learn these trivial commands above.

Install it with an apt-get install firmware-realtek command. Reboot.


If it solves your problem, we are happy. If not, which is an unfortunately probably case, then your hw is buggy (which win7 can handle, but linux can't), or the linux driver is buggy.

Realtek is unfortunately notorious from its BAD hardware and BAD drivers on Linux. In the future, if you can choose hw, remember this s...ing and google for a realtek-free solution if you can. Atheros chips have a very good reputation in linux circles. (Beware: knowing the name of the producer doesn't mean you know the chipset. Atheros, realtek, etc. sell only the chips, which will be built into the different devices sold under other company names. You have to google a little bit before you buy.)


Here is a workaround which you can do in similar cases: if you unload the kernel module, and then reload it again, it will effectiely reset the hardware. To do that,

  1. first shut off wifi (f.e. ifdown wlan0 or similar)
  2. remove the module (it is named probably rmmod rtl8723be (maybe it has some other name on your system))
  3. reload it again (modprobe rtl8723be)

If you are a beginner in Linux, don't worry because of its complexity. 1) These are hardcore things 2) In the reality, they are trivial tasks.

It is highly probably that you will confront obstacles and further problems, in this case here is this site to solve your problems, too.

  • Hi @peterh, thanks for your workaround. I'll try this the next time it breaks. Unfortunately I already had firmware-realtek installed, so that method hasn't seemed to have worked. Thanks also for the information on reliable producer of chips for Linux - I'll definately consider this next time. – andyandy Sep 12 '15 at 17:22
  • @andyandy 1) If you have firmware-realtek installed, then this message shouldn't have appeared on boot. Could you check it again? Maybe there is another problem as well. What is the output of ls -l /lib/firmware/rtlwifi/rtl8723befw.bin, is the firmware file really there? 2) I wait you here after your next reboot, although it would be maybe more useful if you would ask your other questions as new questions. 3) If an answer solved or essentially solved your question, you can accept it by clicking the pipe icon on the left. It is a reward to me, and useful info for the googlers of the future. – peterh - Reinstate Monica Sep 12 '15 at 17:47
  • $ ls -l /lib/firmware/rtlwifi/rtl8723befw.bin -rw-r--r-- 1 root root 30996 Jun 16 2014 /lib/firmware/rtlwifi/rtl8723befw.bin Also I tried upvoting your answer, but I don't have enough reputation :-( – andyandy Sep 12 '15 at 17:49
  • @andyandy And despite that you see the error message after reboot? (Actually, reboot is not needed to test that, a module reload tries to load the firmware again.) – peterh - Reinstate Monica Sep 12 '15 at 17:49
  • Which error message? – andyandy Sep 12 '15 at 17:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.