2

I copied some files from an Archlinux computer to an Ubuntu one, but the time on the files after being moved showed as exactly 2 hours earlier than on the computer they were originally. (2 hours I'm guessing has something to do with the timezone being +0200.) Why do the times appear different though?

Here's timedatectl on the source (Archlinux), where the file modification times were the correct ones. Time was set up by doing ln -s /usr/share/zoneinfo/Europe/Berlin /etc/timezone, then installing ntp and then starting ntpd (systemctl ntpd start).

      Local time: Sat 2015-09-12 10:01:40 CEST
  Universal time: Sat 2015-09-12 08:01:40 UTC
        RTC time: Sat 2015-09-12 08:01:40
        Timezone: Europe/Berlin (CEST, +0200)
 Network time on: no
NTP synchronized: yes
 RTC in local TZ: no

Here's timedatectl on the destination (Ubuntu), where the file modification times were showing as 2 hours earlier than they should have been. I didn't do any special configuration to the time/date settings other than Ubuntu's default setup.

      Local time: Sat 2015-09-12 10:01:40 CEST
  Universal time: Sat 2015-09-12 08:01:40 UTC
        Timezone: Europe/Berlin (CEST, +0200)
     NTP enabled: yes
NTP synchronized: no
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  Sun 2015-03-29 01:59:59 CET
                  Sun 2015-03-29 03:00:00 CEST
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  Sun 2015-10-25 02:59:59 CEST
                  Sun 2015-10-25 02:00:00 CET

Some other things I'm wondering about the Archlinux system's output is why doesn't it show any information about DST and why does it say 'no' for 'Network time on' if ntp is enabled?

closed as unclear what you're asking by Gilles, Anthon, G-Man, Raphael Ahrens, muru Sep 13 '15 at 8:57

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Your text does not mention what command did not work for you as expected and how you did notice the problem. – schily Sep 12 '15 at 11:27
  • 3
    To resolve whether it is a TZ setting, or the wrong timestamp is set on the files, try TZ=UTC stat some_files on the two computers; if the timestamps are the same, then it is a TZ issue. – thrig Sep 12 '15 at 14:17
  • 1
    How did you copy the files? – Gilles Sep 12 '15 at 21:15