0

So my system entropy is low on my centos 6 VM. (137) and I installed haveged,

Yum install haveged

But when I go to start the process it instantly dies:

Process is dead but sub system is locked

Of course I did my research and found no answers why this is happening. I do see that the lock file is there. I've tried deleting it and restarting the service and that did nothing.

I also do not see a PID file in var/run

I installed this from the standard Repos with centos which I assume work since yum installed it fine.

  • You should add some basic information, like the complete command you used to start the process including the complete output of that. Also the output from e.g. ps auxwww | grep -i <processname> afterwards would help. Also check for a log file in /var/lock or /var/lock/subsys. Some related information on that can be found at e.g. serverfault.com/questions/26276/… – doktor5000 Sep 13 '15 at 15:08
-1

You cannot add haveged to a container because it shares the kernel with the host.

  • Define container. The OP wrote "VM" so if it's something like e.g. a virtualbox vm it does not share the kernel with the host. haveged might not be the best solution to the problem, as discussed in e.g. security.stackexchange.com/questions/34523/… But even if it would share the kernel with the host, I don't see any technical reason why haveged would not be able to run in, say an systemd-nspawn container - in fact it's often recommended for containers that run SSL-related payloads. – doktor5000 Sep 13 '15 at 15:18
  • It's a container. It is sharing the kernel as both entropy on host and guest is the same. Most people surprisingly don't know what a container is so I use VM. :) see my other post with a ton more info: serverfault.com/q/721654/279772 – Gordon Snappleweed Sep 13 '15 at 15:29
  • I tried deleting the subsys lock file. Still dies. This is when I was told it won't run on a container because the kernel would only take inhibited entropy from the host. Is that correct? My host is CL and I'm not even sure haveged runs on CL – Gordon Snappleweed Sep 13 '15 at 15:30
  • You did not even mention what kind of container you run that mail server in. And as CentOS also runs a normal linux kernel, why should haveged not be able to run on the host? – doktor5000 Sep 13 '15 at 15:41
  • Sorry - container is centos. Host is cloud Linux. Haveged won't run on centos, and CL doesn't have it built in a repo and building from the source isn't working either. If I can get it to work on the container (centos) even though it's sharing the kernel with the host (CL) then I'd love to do that. – Gordon Snappleweed Sep 13 '15 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.