0

I have a local machine with CentOS 7. There is a Socks V5 proxy server on the local subnet that provides this machine with access to the internet. I am able to download files with,

curl -x --proxy socks5://ipaddress:1080 -u username:password www.google.com

On my local machine I am currently running Artifactory and Jenkins webapps in Tomcat. The systems do not natively provide socks proxy setup; and require access to the internet.

I tried tsocks, however remote DNS requests are not resolved.

How to I get this working?

0

So what you provided was the proxy for the curl program to use for that single request.

You may wish to try setting the http_proxy and https_proxy environment variables and see if your programs pick them up.

e.g.

  • export http_proxy=username:password@proxy.com:8080

These variables would need to be set again on any reboot, so not ideal.

If you are not comfortable with storing these credentials in clear-text in an environment variable you may look to opt for a more robust solution such as cntlm:

  • Its not an HTTP proxy, but a SOCKS proxy. Exporting http_proxy does not work. – erichfw Sep 11 '15 at 11:14
  • http_proxy=socks5://127.0.0.1:8080 For example... – Douglas Rae Sep 12 '15 at 19:29
  • Cntlm if you need something to last longer / not leaving passwords in cleartext etc – Douglas Rae Sep 12 '15 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.