I'm new to RHEL (haven't used it since the early 2000s when it was still open source) and currently attempting to install it on a cluster of machines. I'm trying to automate this process as much as possible.

To that end, I've created a custom kickstart file ks.cfg and placed it on a webserver (http://url.com/ks.cfg). I've also placed the RHEL 6.7 server ISO on the same webserver, and created a minimal boot image on a USB drive that can handle my machines (UEFI). It boots off the USB stick just fine.

However, I reach the same GRUB menu as the user in this somewhat-related question. It appears to be grub 0.97, rather than the GRUB2 all the tutorials I've found online are using. Of particular note, this version does not seem to recognize the critical linux command, which all the tutorials I've found reference for appending the ks= arguments.

In short, how do I bring up the boot: prompt so I can issue the linux ks= command? Any help is appreciated!

(and if you want to throw in some information on how to set up a PXE server for fully-automated network installs, I'm all ears; the documentation is not particularly helpful, at least in terms of the PXE server specifically)

1 Answer 1


Easiest might be to tweak the efidisk.img to do what you want, something along the lines of:

cp /that/cdrom/efiboot.img /root
mount -o loop /root/efiboot.img /mnt
cd /mnt/EFI/BOOT

and there should be a (under RHEL7 or equivalent) grub.conf. Then, edit that, in particular the linuxefi line inside the menuentry 'Install ...' block, to contain something like

        linuxefi /images/pxeboot/vmlinuz inst... ks=http://... quiet

then unmount that, redd the image over to the flash drive, lather, wash, rinse, repeat.

On RHEL6, look for a BOOT*.conf file, which has PXE boot config lines with title; try adding an append line with the kickstart argument:

title Red Hat Enterprise Linux 6.7
        kernel ...
        initrd ...
        append ks=http://...

(You may also need ksdevice=eth0 net.ifnames=0 biosdevname=0 arguments to force use of the "first" network card and to turn off wacky device naming, from digging around in our build system.)

PXE setup is somewhat involved, as you need to offer DHCP, TFTP, and usually also HTTP to serve files from, plus maybe DNS, and there's particular fiddly bits you need to get right in all of those services, in addition to getting a valid kickstart file going. Something like the http://www.rocksclusters.org/wordpress/ project might be worth looking at for "a cluster", in lieu of delving deeper in to the redhat docs.

  • Huh, this is interesting. When I run kpartx and then mount (I have to modify the argument to be mount -t vfat /dev/mapper/loop2p1 /mnt), I get the /mnt/EFI/BOOT folder but it only contains 5 files: BOOTX64.conf, BOOTX64.efi, initrd.img, splash.xpm.gz, and vmlinuz. Did I mount the wrong EFI partition?
    – Magsol
    Sep 10, 2015 at 19:48
  • 1
    Oh, I was poking at a Centos 7 image. cough Let me find something from RHEL6...
    – thrig
    Sep 10, 2015 at 20:01
  • If it wasn't for my uni's Satellite subscription, I'd almost just go with CentOS at this point...
    – Magsol
    Sep 10, 2015 at 20:14
  • Okay, just tweak the BOOTX64.conf. Similar, but different.
    – thrig
    Sep 10, 2015 at 20:19
  • Silly question: after editing the file and unmounting the directory, how do I recreate the image with the new conf file?
    – Magsol
    Sep 10, 2015 at 20:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .