4

I have a 10-bit H264 video, but I can't play it in Totem or VLC. I tried recompiling libx264 with 10-bit support after removing libx264-116, but it doesn't seem to work. VLC does not use GStreamer, but seems to also use libx264.

enter image description here

4
  • Any chance you can add a link to an example of such a video?
    – fossfreedom
    Oct 2, 2011 at 19:12
  • Have you tried installing libavcodec-extra-52 from Medibuntu repository? medibuntu.org/repository.php
    – Stefano
    Oct 2, 2011 at 20:06
  • fossfreedom: I don't have a small video file. What I have here is a 169MB file.
    – Arnel A. Borja
    Oct 3, 2011 at 5:47
  • Pisu: I tried it, but still didn't work.
    – Arnel A. Borja
    Oct 3, 2011 at 5:48

4 Answers 4

1

Have you tried mplayer? According to MPlayer 1.0rc3 release - it support 10-bit H264 videos. And for a nice GUI for mplayer, you could checkout smplayer

3
  • I currently use MPlayer2 and SMPlayer, but Totem (and GStreamer) are faster in my netbook and my desktop. I can't even play videos in SMPlayer in my netbook - I need to move the videos to my desktop to view them (though a lot of times, the video gets unsynchronized with the audio). Other videos play fine in Totem on my netbook. Feb 12, 2012 at 4:32
  • @ArnelA.Borja Have you tried using testing repository or compiling from source? sometimes the current repositories aren't that up-to-date or some bug fixed upstream might not have synced up in the repositories yet.
    – Maverick
    Feb 12, 2012 at 14:06
  • I use Ubuntu not Debian, but I use the Precise Alpha 2 (which is based on Debian Testing). I also tried to compile from source before. Feb 12, 2012 at 22:00
0

Install Ubuntu Restricted Extras.

1
0

You need to recompile gstreamer0.10-ffmpeg with your libx264 compatible to 10 bits h264 codec. Or compile VLC with it. Remember to use the correct --prefix in ./configure. I recommend using VLC in this case.

1
  • I tried to recompile the packages from the Ubuntu repositories but it still doesn't work. Maybe there's something missing? I used the x264 (added 10-bits option), libav and gstreamer0.10-ffmpeg source packages.
    – Arnel A. Borja
    Oct 7, 2011 at 10:00
0

VLC 1.2.x (from the nightlies) and Mplayer2 supports h264 10 bits depth.

1
  • 1
    I'm currently using Mplayer2 and VLC from the Ubuntu PPA play 10-bit h264 videos, but they are slower compared to Totem (especially unstable VLC, the video is unviewable, while the video in Mplayer2 always gets unsynchronized with the audio). Dec 25, 2011 at 6:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.