0

I want to install lipXp-devel-1.0.0-8.1.el5.i386.rpm and get the error message:

Package: lipXp-devel-1.0.0-8.1.el5.i386
Requires: libXp = 1.0.0-8.1.el5
Installed: libXp-1.0.0-15.1.el6.i686

How can I install the the rpm?

0

No you are misjudging it. Your rpm file version is older and you have installed CentOS6.4 requires el6 package, which is NOT compatible to your system.

You need to install lipXp-devel package compatible to your installed libXp-1.0.0-15.1.el6.i686 package. This package is available on rpm.pbone.net
Try installing this package.

  • @nguvi: If you find my answer helpful and resolved your issue, Please mark the answer accepted. So that, it will come at top of other answers and will helpful to others who refer this question. – Tejas Sep 16 '15 at 9:07
  • Sorry for the late reply and thank you for the quick answer! I had to experiment a little but you explanation put me on the right track! – nguvi Sep 18 '15 at 6:55
0

Try to install the el6 version of libXp-devel to avoid a lot of dependency issues. If you have the el6 repository configured you should be able to search for the correct version using yum search libXp-devel and to install the package (including dependencies) using yum install libXp-devel

To configure the el6 repo you can use:

rpm -Uvh http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm

See http://repoforge.org/use/ for details.

You can also use the 'community approved repository':

rpm -Uvh http://www.elrepo.org/elrepo-release-6-6.el6.elrepo.noarch.rpm 
yum install yum-plugin-fastestmirror

See https://wiki.centos.org/AdditionalResources/Repositories and http://elrepo.org/tiki/tiki-index.php for details.

  • Thank you for your comment! i configured the repositories! – nguvi Sep 18 '15 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.