An application I'm working on writes the network settings by updating the /etc/sysconfig/network/ifcfg-* files. Unfortunately these settings are not reloaded because every time I do ifconfig there is no IP on the interface I'm updating.

I tried adding ONBOOT='yes' to that file. Also ifconfig eth0 up. And ifup eth0 but it ends up with a timeout error.

But if I do ifconfig eth0 for example it works but that IP does not appear in the ifcfg-eth0 file for examples.

So my questions are:

  1. By setting the IP using ifconfig, Where is the location of these settings is stored ?

  2. In my situation where I write to the ifcfg-eth0 how to reload the settings from that file ?

Note: The machine that I'm working on has no NetworkManager.

Note 2: The machine is on a remote location and I'm connecting to it through SSH using putty.

Note 3: As of this documentation page section the command ifup will bring the interface up and reads its corresponding configuration from ifcfg-* file. Somehow the command ifup eth0 ends up with

wicked: device enp2s0: operation timed out
enp2s0          setup-in-progress

2 Answers 2


You can do a /etc/init.d/network restart this is usually reentrant and will only change what is updated.

ifconfig is an interactive tool which only relies on what you provide as argument, those arguments are not saved somewhere.

  • There is no network script under /etc/init.d/. I tried service network restart and it did not work. I don't know why there is no network script, I did not install that machine.
    – 3bdalla
    Sep 10, 2015 at 9:42
  • And by didn't work I mean that ifconfig does not show the new IP in that file.
    – 3bdalla
    Sep 10, 2015 at 9:43
  • It seems this version of suze is based on systemd and not init.d, this might explain why you have nothing in /etc/init.d/
    – netmonk
    Sep 10, 2015 at 9:45
  • The directory /etc/init.d/ exists and there is network conf files like ifcfg but no script called network. OK there is a `systemd directory where to go there ?
    – 3bdalla
    Sep 10, 2015 at 9:48
  • 1
    i see you have wicked, then you should read suse.com/documentation/sles-12/book_sle_admin/data/…
    – netmonk
    Sep 10, 2015 at 12:52

For systemd and later

sudo systemctl restart network

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.