2

My root filesystem is mounted read-only.

I have installed wicd, but it fails to work with following error:

 IOError: [Errno 30] Read-only file system: '/etc/wicd/manager-settings.conf'

It seems, every time I restart wicd, the configuration file is rewritten, but the content is the same.

Any suggestion how to fix this?

2

You can change the location of the config files in /usr/share/wicd/daemon/wicd-daemon.py

So, if /etc/wicd/ is readonly, move them to /var/lib/wicd/:

i.e.:

wireless_conf = "/var/lib/wicd/configurations/wireless-settings.conf"
wired_conf = "/var/lib/wicd/configurations/wired-settings.conf"

self.config = ConfigManager("/var/lib/wicd/configurations/manager-settings.conf")
1

I suggest you do one of the following:

  • Make /etc/wicd/manager-settings.conf a symlink to a file on a filesystem that is not read-only (whether this works or not will depend on the application logic) -- the advantage of this approach is that it only affects this single file;
  • Bind mount /etc/wicd to a directory that is not on a read-only filesystem -- a disadvantage of this is that you have to do this on the granularity of a whole directory, but perhaps you can change the config file location so that this isn't an issue;
  • Have a separate mount for /etc/wicd -- again, a disadvantage is that this is at the granularity of a directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.