2

I have an issue when I want to rsync folders from my external backup hard disk to my NAS.

I get this error :

read errors mapping permission denied (13)

I have root rights; if I want to change the user's right via chmod, nothing changes. With Windows, the owner is changed but the copy doesn't work.

S.M.A.R.T tests is OK.

The ntfsfix tests provide no error.

I tried to made an chdisk from windows with no results.

Do you have any idea for repair or a tricks to recover my files ?

1
  • Are you sure it says read errors mapping permission denied (13) and not read errors mapping {filename}: permission denied (13), for some value of {filename}? Please update your question with the exact error message and also the rsync command line you used. Sep 16, 2015 at 22:43

1 Answer 1

0

I have a similar issue and have identified a potential cause. In short, I believe that this is caused by corruption of the source data as I have since proven that other copy commands (cp) and basic reading of the files (less) give read errors. I have not attempted to identify/fix any file system errors.


I am trying to duplicate the contents of one (large internal RAID) partition to a (smaller) USB drive, which has sufficient space for all the data. Both are formatted with ntfs (I'm solving a Windows-10-unexpectedly-does-not-support-my-RAID-card issue). I am using a MintOS image on a USB stick then copying the files using rsync -a Source/ Destination.

A handful of files, all in a single directory, generate errors each time I run the command. The files themselves include a text (.txt) file, a PDF (.pdf) file and five binary disk image files (.dsk).

The errors seen are similar to these:

rsync: read errors mapping "full_file_path": Permission denied (13)
...
ERROR: <folder>/<filename> failed verification -- update discarded.
...
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1183) [sender=3.1.0]

It looks like the first entry, including the Permission denied (13) bit, happens twice, which I believe to be rsync attempting to copy the file twice.

If I try to copy the files using cp I get the following errors, with zero-sized files created on the Destination.

cp: error reading ‘path_to_Source_file’: Permission denied
cp: failed to extend ‘path_to_Destination_file’: Permission denied

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .