In Linux Mint KDE 17.2 (KDE4) the Google search fonts are different than in other systems.

enter image description here

In Linux Mint Xfce 17.2 (that is, the same OS, different DE), it is normal one, that is the one that I prefer and have on the other systems that I tested (Ubuntu Unity, Lubuntu, Manjaro KDE5 and Netrunner KDE5, Kubuntu 14.10 (KDE4), Windows 7 and 10, and this no matter the browser (Firefox, Google Chrome):

enter image description here

So, this is not browser specific. the same happens in Chrome and Firefox, it is system specific. I have tested from live USB different OSes that use KDE, it only happens in Mint 17.2 KDE. Kubuntu 14.10 which also uses KDE4 is not affected.

The most common font, and the one that I prefer to have is Arial I guess, while the other one may be Segoe. I think I have seen the latter in other systems/desktops but trying to check this I couldn't confirm.

I have customized the KDE fonts (FreeSans all around) but the system settings don't seem to affect this.

The place where I see this kind of difference more clearly is Google Search results page. But I expect it to be present in other Google services.


This affects other Google services like Gmail and Google Translate, but not Youtube and Google+.

I have even tried to see if the same difference is present between Firefox for Windows installed under Playonlinux in LMint Xfce and LMint KDE: yes, the same difference!

Note pending deletion of this question.

This was a temporary cross-posting of a superuser.com question which received an answer HERE. I will delete this one but cannot before the bounty expires.

This questio

closed as off-topic by user32012, Archemar, Anthon, cuonglm, Timo Sep 22 '15 at 14:05

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question has been posted on multiple sites. Cross-posting is strongly discouraged; see the help center and community FAQ for more information." – Community, Archemar, Anthon, cuonglm, Timo

  • This problem got a solution posted as a comment by Kevin Follstad under this question temporarily cross-posted on superuser.com. – user32012 Sep 11 '15 at 20:20
  • Do you have the Arial font installed? What does fc-match arial say? – contemplator Sep 12 '15 at 19:53
  • @contemplator - yes, arial was there. see the answer linked – user32012 Sep 12 '15 at 22:24
  • I want to delete this question but I cannot now, as it has an answer. I have flagged it to be closed. It was also posted and answered on superuser, as seen in the link posted in the update above. – user32012 Sep 22 '15 at 12:00

Google uses the Arial font to display its results.

Using Opera, I did a random search and then invoked the developer tools to view the CSS.

Opera Developer Tools, Google Search Results

You will notice, that it uses "arial" first then falls back to "sans-serif" if that font dosen't exist. What you are seeing is either the sans-serif font installed on your machine or its closest equivalent.

Fonts exist on your Operating System not on your browser per se. This is why Arial looks the same no matter what application you are using whether it is a word doc, a spreadsheet or a webpage.

Linux has equivalents - I ran across this article which explains this further: Linux Font Equivalents to Popular Web Typefaces

To install Arial on Linux mint do the the following:

  1. Download the TTF (TrueType Font) from here
  2. Install the font by double clicking on the TTF font you extracted from step 1

Try your Google search now. You should see results in line with what you are expecting.

  • Arial was already installed. For some reason it was not used.The solution was the one in the answer linked in the updated question above. I should have deleted question and keep the one on superuser, and I will, only I cannot before the bounty expires. - Thank you for your effort. – user32012 Sep 14 '15 at 20:45