How do I prevent upgrading to ubuntu 12.04.5 from 12.04.4 when running

sudo apt-get update

in the terminal?

I am using

CAELinux xubuntu 12.04.4,
Asus N53s laptop,
Nvidia GT540M Graphics card

  • sudo apt-get update neither upgrade to any point release nor install any package..all it does is syncing the local repo package list with the original repo package list.. – heemayl Sep 7 '15 at 19:45
  • I am new to linux. I will update the question. But I want to know how to prevent updating 12.04.4 to 12.04.5 in general. I have had to reinstall 5 times now to get back to 12.04.4. – BaisJohn Sep 7 '15 at 19:56
  • 1
    Why won't you want to upgrade to 12.04.5 ? point releases normally come with bugfixes.. – heemayl Sep 7 '15 at 19:57
  • There is a problem with my nvidia graphics card. If I upgrade to 12.04.5 then I can not start my computer off the battery. I need to plug it in to start it. Once it is started I could unplug it and run for a few hours. I have spent weeks trying to solve the problem and the only solution I found was to stay with 12.04.4 – BaisJohn Sep 7 '15 at 20:01

Do not run :

sudo apt-get dist-upgrade

I am not aware of anything that could be used directly to prevent upgrading from a point release to another but if you don't run dist-upgrade then no new packages will be installed or removed from the system so essentially you will be sticking to the 12.04.4 release.

From man apt-get :

dist-upgrade: dist-upgrade in addition to performing the function of upgrade, also intelligently handles changing dependencies with new versions of packages; apt-get has a "smart" conflict resolution system, and it will attempt to upgrade the most important packages at the expense of less important ones if necessary. The dist-upgrade command may therefore remove some packages.

Again by preventing from upgrading to latest releases you will be vulnerable to bugs and sucerity issues, you should think about soving the nvidia problem rather that sticking with this solution.

  • Let me know if I need to start a new question for this. The only thing I can think of is that the bumblebee headers are wrong after the update. wiki.ubuntu.com/Bumblebee "If on 12.04.5, replace linux-headers-generic with linux-headers-generic-lts-trusty. " I tried to just do the steps after the upgrade to 12.04.5 from the website. But that didn't work. could this be the problem? – BaisJohn Sep 7 '15 at 21:05
  • @BaisJohn Yeah..that could cause the problem as trusty is 14.04..so its basically installing headers of trusty replacing current one..i think you should ask a new question adding details of current state of nvidia and what happens after upgrading..i mean as much details you can add.. – heemayl Sep 7 '15 at 21:09
  • @BaisJohn Also i think these questions will be better suited for askubuntu..also please mark my answer as selected by clicking the tick mark on the left of my answer so that this issue can be marked as solved.. – heemayl Sep 7 '15 at 21:10
  • I will start a new question, but I started asking this problem on the CAElinux forum, they told me to go to askubuntu. Then askubuntu told me this was off topic and to come here so I am really hoping to get some help for this. – BaisJohn Sep 7 '15 at 21:14
  • @BaisJohn i see..well..then you should ask it here..ithis is a generic site for Unix/Linux.. – heemayl Sep 7 '15 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.