1

I tried modifying global keyboard shotcuts (Kwin): go to Desktop X, go to Desktop right/left.

When I try the keys nothing happens. Maybe there's a visually application to do that? (create new workspaces / switch between them)

2

If you are using the new Plasma5, some say it has problems with keyboard shortcuts (not that I've noticed).

You can easily change workspace by using the "Desktop grid" effect. Once you have enabled it in "Desktop Effects", you can activate it both with a keybord shortcut (CTRL+F8 by default) and by navigating to a window corner, if you have set it up to do so in the "Screen Edges" menu (which you can find with KRunner).

From there you can select, add and remove workspaces.

  • thank you for the very detailed explanations. Unfortunately none of the options work (and they are active). neither +F8 or edges. Any idea? – dragonmnl Sep 7 '15 at 19:56
  • Are you sure desktop effects are active? Can you trigger any desktop effect? – AF7 Sep 9 '15 at 8:02
  • actually I just noticed that in Desktop effects when chooking a new effect I get the error: Desktop effects not running. I searched a solution around but couldn't find a working one – dragonmnl Sep 9 '15 at 22:00
  • The shortcut for activating / deactivating effects is Alt+Shift+F12. Try to activate them, if they don't work (which video card do you have?) try to change rendering method. ou can do that from "display and monitor" > "compositor". Fromthere you can also tweak other compositor options, among which if effectsshould be active at startup. If the compositor finds any problems, it will turn off effects automatically to prevent crashes. This is usually due to video driver problems or very very old video cards (> 8 years old). – AF7 Sep 11 '15 at 7:43
  • thank you for your further explanation. However with Alt+Shift+fn+F12 (with fn since my keyboard gives priority to multimedia options, but I actually tried with configuring simpler keyboard shortcuts) nothing happens and I can't find "display and monitor". I'm on Mint 17.2 and there are just "display" and "display configuration" + "Xserver". My computer is pretty new, bought 1 year ago. NVIDIA GEFORCE (how do I verify what one is the specific model?) of which I upgraded the drivers couple of weeks ago – dragonmnl Sep 16 '15 at 9:55
0

If you go into settings > shortcuts > global shortcuts > kwin, and then search for desktop (only necessary to show only shortcuts related to desktop in kwin, and to have the change desktop options near the top of the list). You can then set up shortcuts for going one desktop to the left, right, up or down. So depending on how you have your desktops laid out, you can re-create the gnome shortcuts here.

As you do this, if you have the Desktop Gird feature enabled, you will notice it here mixed in with all the other options. If you change the desktop grid shortcut the desktop effects, it will change the kwin shortcut as that is what it is using. You can also go to settings > desktop behavior > virtual desktops > switching (tab at the top) to change the desktop switching shortcuts at the bottom which, again, will actually change the kwin shortcut. All that means is that you can freely change the setting in either place to without any problems.

I usually have mine laid out in a single row, so I usually do left and right instead of up and down. you can also use next and previous desktop instead of left, right, up, and down.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.