0

I have a notebook and installed Fedora 21 into it, then I installed virtualbox, then I installed Windows XP as a guest. From the Windows XP, I used the eth0 as the bridge to let the dialer(only windows version exists) to connect to the ISP to access the internet.

Now I want to let the host, Fedora 21, access the Internet, too. So I added another host-only adapter in virtualbox, vboxnet0. it is configured to 192.168.56.1 and dhcp enabled. The guest's ip is 192.168.56.100. The host and guest could ping each other.

Then I added a default route in host: "ip route add default via 192.168.56.100 dev vboxnet0". After this, I this, it should work, but it didn't. I don't know where the problem lies.

Thanks for your help in advance.

  • 1
    Have you enabled Internet Connection Sharing in Windows XP? – garethTheRed Sep 6 '15 at 7:55
  • @garethTheRed Someone said, I should ask this question on superuser.com, I searched and read similar problems and their solutions. After that, I realized I can use program 'squid' to serve as the http proxy server, so I installed squid\openssh into the guest 'windows xp', then I use ssh port redirect to enable the Internet Sharing between the host and guest. – zhangjie Sep 15 '15 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.