1

I have been working with RC for a long time and I know some awesome SQL tweaks that work wonders, etc. My tweaks haven't done a single thing for the kolab install. This the first time I've worked with memcache. So here's my config before I proceed:

// IMAP Server Settings
$config['default_host'] = 'localhost';
$config['default_port'] = 143;
$config['imap_delimiter'] = '/';
$config['imap_force_lsub'] = true;

// Caching and storage settings
$config['imap_cache'] = 'memcache';
$config['imap_cache_ttl'] = '10d';
$config['messages_cache'] = 'db';
$config['message_cache_ttl'] = '10d';
$config['session_storage'] = 'db';

// SMTP Server Settings
$config['smtp_server'] = 'tls://localhost';
$config['smtp_port'] = 587;
$config['smtp_user'] = '%u';
$config['smtp_pass'] = '%p';
$config['smtp_helo_host'] = $_SERVER["HTTP_HOST"];

I did notice that when I turn off tls on:

$config['smtp_server'] = 'tls://localhost';

that I can't log into RC, it seems to want to force me to use TLS, which I read somewhere else. Not sure if this is the culprit here.

CHATTRSYNC is off on cyrus already (by default I guess?)

I've installed imapproxy which seems to be working as far as the logs are concerned, but I STILL get about 3-4-5 second delay when opening through email. I have since uninstalled the imapproxy... Memcache is working properly according to the simply ps aux command or memcache-tool command but it still seems slow on RC, doesn't seem to have made a difference. I get these constant logs:

Sep  5 20:54:51 es1 imap[2281]: login: localhost [::1] johndoe@domain.com PLAIN+TLS User logged in SESSIONID=<es1.domain.com-2281-1441500890-1-15740725055571902363>
Sep  5 20:54:51 es1 imap[2281]: USAGE johndoe@domain.com user: 0.009998 sys: 0.006999

It logs everytime the user makes a click or opens an email. Again, imapproxy didn't work much.. I tried disabling TLS, tried changing the cache methods.. Have been doing research pretty much all day trying to tweak this. Some have said comment out the kolab files plugin, that didn't make any difference at all. Cyrus just seems to take forever for some reason.. I am talking 4-5 seconds waiting before the email even shows on the screen.

memcache conf:

PORT="11211"
USER="memcached"
MAXCONN="1024"
CACHESIZE="1024"
OPTIONS="-l 127.0.0.1"
OPTIONS="-vv >> /var/log/memcached 2>&1"

I tried increasing cache size, didn't help (not that I thought it would either)... I am getting a little desperate here.

I changed php.ini to memory_limit = 4096M... Already kicked up my innodb performance settings tuned like my fast non-kolab servers.. I don't think its a mysql problem either.. The problem is with the

Any ideas as to why this is so slow compared to my non-kolab RC install I have going right now (dovecot based)?

By the way, this server has two active email accounts on it.. No load what so ever.

Kolab 3.4, centos 6

I am not sure what else to try. Can someone suggest something? I am trying to figure out how to optimize Cyrus, so that is probably my main question.. Whats the best way to optimize cyrus imap? I am running 2.6

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.