0

I've had some trouble installing a dual-boot system on my laptop. I used Boot-Repair and now both systems (Windows 10 and Kali Linux 2.0) are showing up in Grub.

My problem is that, whenever I start Linux it just starts a terminal. I've tried to check if the desktop environment is still installed but I just get:

W: Not using locking for read only lock file /var/lib/dpkg/lock
E: Unable to write to /var/cache/apt
E: The package lists or status file could not be parsed or opened.
  • Please post the exact command you're running – Wouter Verhelst Sep 5 '15 at 11:00
  • I tried to install gnome to display if its already installed: 1. apt-get install gnome-shell – Tim G. Sep 5 '15 at 11:22
1

It looks like the installation of kali did not finish. You may be able to correct the problem by running apt-get update first, and then installing gnome-shell as you were trying; however, if the packages weren't installed properly, there's a good chance that many other things failed as well, leaving you with a badly functional system even if you can get this problem resolved.

I would suggest that, rather than trying to fix the broken installation, you just do the installation again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.