3

I have just started using fvwm window manager, and I am using xombrero browser on OpenBSD. (update this is gtk issue not window manager)

However, the color of the address bar, search box, and command box are all white (or off-white) text and white (or off-white) background. Highlighting the text also is white. So it's impossible to read the input text.

Input forms within the page are colored fine, although highlighting causes white on white.

I looked through the xombrero man pages but found no reference to any way of changing the color of any of those items. Therefore I thought this is maybe controlled by fvwm through some FvwmForm parameter.

I tried adding *FvwmFormBack Black to my .fvwmrc file and reloading fvwm, but it didn't seem to fix anything.

Anybody know what and where is the control parameter for the (a) background and text color of (web browser) input fields, and (b) the highlighting color for fvwm?

(Or if this is absolutely not a fvwm issue, please let me know, but I would pretty surprised if the creators of xombrero would make white on white text be default and not configurable).

This is a gtk3 issue I didn't have a gtk3 theme installed. Gtk3 is used to control the relevant input fields. To fix it, I installed a theme into ~/.themes/THEME_NAME folder, and added the following to /etc/gtk-3.0/settings.ini:

[Settings]
gtk-theme-name = THEME_NAME

But that is only for one user. How can I install the system default gtk3 theme?

I searched for relevant man pages but came up dry for good gtk3 reference.

2

Gtk3 is used to control the relevant input fields in xombrero and some other gui unix apps.

In this case, I was missing a gtk3 theme, and the default text color apparently was white.

To fix it:

Option 1: gtk theme

  1. Download (lightweight) gtk3 theme (if you dont have one already)
  2. extract it into~/.themes/THEME_NAME folder
  3. added the following to /etc/gtk-3.0/settings.ini:

    [Settings] gtk-theme-name = THEME_NAME

Note this fixes the issue for a single user, but is not very good solution, because the system settings file points to a theme that is not installed for all users. I hope sonebody else has a way to install for entire system.

Option 2: change the xombrero gtk file

(Thanks to xombrero mailing list)

In the file /usr/local/share/xombrero/xombrero.css, change the following

old:

.entry { padding: 2px; color:@text_color; }

new:

.entry {padding: 2px; color: black;}

This method might cause issues if a dark background for gtk theme is used though.

| improve this answer | |
  • Just editing the css file helped me, for getting started. – Nikos Alexandris Dec 27 '15 at 19:23
  • /usr/share/xombrero/xombrero.css on Debian Jessie – lauhub May 11 '17 at 9:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.