I am trying to install SLES on a server with 8 HDDs, 3 TB each, but I am testing the configuration first on a VM (virtualbox).

I tried following configurations and both got me stuck at the EFI Shell:

  1. the first 200 MB are allocated to /boot/efi, only the first HDD is mounted, the others I planned to clone according to this description. The remaining space was combined to a RAID6 array containing root, swap, home
  2. /boot/efi on the first 3 HDDs [sda1, sda2, sda3 - also according to the link above], system partition on a RAID1 on the first 3 HDDs [sda2, sdb2, sdc2]. The remaining space was used for RAID6, containing swap, home, etc.

I also tried to boot from a rescuecd (I also have no clue how this works, but I'm improvising) and mounted EFI. It actually seems like there are 2 folders containing files in brackets:

  • boot [bootx64.efi, fallback.efi]
  • sles12 [boot.csv, grub.cfg, grub.efi, grubx64.efi MokManager.efi, shim.efi]

Also the /etc/fstab file on system partition seems ok.

So my question: Did something go wrong during the installation? Do I miss some EFI setup commands? I don't fully understand the booting process, so i can't figure out where to start...

  • You might be better off adding a separate system drive, maybe an SSD or USB Flash in an internal USB slot, I haven't seen a sane way of doing UEFI with software RAID so far (please share if you find one). Note that vbox's implementation of this mode is, erm, somewhat specific. And last, there's a good EFI intro out there: rodsbooks.com/efi-bootloaders/principles.html – Michael Shigorin Sep 5 '15 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.