2

I installed foomatic to try and find a PPD file for my HP OfficeJet J4680 printer. However it does not have one for my specific printer in its foomatic-ppdfile list. Is there a way to manually generate a PPD with foomatic for my specific printer or should I try another source such as Gutenprint or CUPS SDK? Or is there a PPD file that is close to what I have that would work?

2

Try installing hplip, it should contain the driver for your printer.

http://hplipopensource.com/hplip-web/models/officejet/officejet_j4680_series.html

  • You may also install hpijs for good measure. Both are in the fedora repos, so a yum install should do the trick. – Klaatu von Schlacker Sep 3 '15 at 21:14
  • Did that already on the first go round. It bombs out on a dependency (usblib) saying I don't have it installed when I do. and I'm not sure how to resolve that. I thought the foomatic approach would be easier. – user53029 Sep 3 '15 at 21:33
  • I tried your link. Its actually a newer version than the one I tried however it also fails at libusb saying I don't have it it installed when I do. – user53029 Sep 3 '15 at 22:33
  • It has got to be a bug in the hplip app. I just updated to libusb for FC22 and it still says libusb missing. – user53029 Sep 3 '15 at 23:13
  • Its crazy how fickle Linux can be at times. After I updated LIbusb and restarted the PC, (and after the re-install of hplip failed due to "missing libusb") In CUPS web admin I was able to see my printer, add it, and print to it no problems. Weird...but in a good way.. – user53029 Sep 4 '15 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.