2

When I put a vmware workstation in fullscreen mode, I am unable to click on things on the left edge of the virtual machine because Ubuntu captures the clicks and opens up the corresponding application on the unity launcher panel. For example when I go to open steam in windows in the image below it opens libre office in ubuntu instead:

vmware with windows guest in ubuntu

I'm using workspaces, so is there some way I can disable the ubuntu launcher and panel on a specific workspace? I basically want one workspace dedicated to a virtual machine. Are there any other workarounds?

I have the same problem with clicking on vmware menu items (it clicks on the ubuntu top panel instead of the vmware drop down menus).

3

Not 100% sure that this will solve your problem, but I've had the same issue and at an initial look an idea from this thread seems to have improved matters.

To quote the relevant answer in that thread.

My solution was:

If you have Compiz enabled (as in Unity by default):

sudo apt-get install compizconfig-settings-manager

Then, in Control Center: Personal / CompizConfig Settings Manager check Utility / Workarounds / Legacy Fullscreen Support.

  • Will test this when I have vmware running again - have since moved to arch linux, though I do still use compiz so it should be applicable. – cronburg Jan 4 '16 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.