I'm trying to get my new Realtek RTL-8169 NIC (over CardBus) to work, but I'm having this weird problem. My lspci -x output looks like this:

[root@comp]# lspci -x -d *:8169
07:00.0 Non-VGA unclassified device: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev ec)
00: ec 10 69 81 00 00 00 00 ec 10 69 81 00 00 00 00
10: ec 10 69 81 00 00 00 00 ec 10 69 81 00 00 00 00
20: ec 10 69 81 00 00 00 00 ec 10 69 81 00 00 00 00
30: ec 10 69 81 00 00 00 00 ec 10 69 81 00 00 00 00

. Does this mean the card is messed up? PCI configuration registers are looking crazy, they only contain vendor and device id repeatedly. The contents should definitely be different, and when I try to write to them with setpci, the values just stay the same.

Does anyone know what might be wrong?


No, missing pci ids don't cause the buggy output, their query is independent from the driver (it is even possible, when there is no driver for the actual pci device loaded).

The replays in the pci registers don't mean anything okay, and it isn't look as a driver problem! It seems to be a mainboard/nic incompatibility or as hw failure (in mainboard or in the nic).

Writing the pci registers isn't always possible, it depends on the card if it let it or not.

In your place I did some like a hw debug: tried the card in another pci slot, or in another machine, or with another os, only to find, where is the weak point in your system.


Perhaps that card is missing in pci-ids? Have your tried to download a linux-driver for that card from Realtek?

  • lspci read from HW, not from pci-ids DB.Driver has nothing to do with output from lspci. – rkosegi Sep 22 '12 at 11:50
  • @rkosegi I may cite from man lspci: FILES /usr/share/hwdata/pci.ids A list of all known PCI ID’s (vendors, devices, classes and subclasses). Maintained at http://pciids.sourceforge.net/, use the update-pciids utility to download the most recent version. – Nils Sep 23 '12 at 20:49
  • @Nils No, if it were missing, lspci give output lines about an unknown device. This is because I think there is a comm/compat error of a buggy hw. I've seen hw already who gave somehow bad pci id, although it functioned well (only it needed some "change" below /lib/modules). – peterh May 26 '14 at 9:34
  • @Peter What about the unclassified device output? – Nils May 26 '14 at 19:15
  • @Nils I don't understand the your question very well, but the pci regs are readable of an unknown device as well, and this is because this happens on a driver-independent manner. – peterh May 26 '14 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.