0

I have installed windows 10 in my laptop in BIOS Legacy mode.I have 3 primary partitions including the Windows partition and have extended partition with 2 more logical partitions.

Now for installing Arch-Linux I created 4 more logical partitions for /boot,root,swap and /home in that order under the extended partition. So this is how it looks:

sda1 primary 163gb ntfs
sda2 primary 175gb ntfs
sda3 primary 175gb ntfs
sda4 extended 185gb
    sda5 logical 100gb ntfs
    sda6 logical 10gb ntfs
    sda7 *(boot) logical 400mb ext4 
    sda8 (root) logical 23gb ext4
    sda9 (swap) logical 4gb linux-swap
    sda10 (home) logical 50gb ext4

I have an arch linux live usb through which i booted and installed the base system.I installed grub and then restarted. Now the problem is the grub wont load and system is into infinie restart loop just showing this:

exiting pxe rom

then exiting pxe rom and restarts back to this screen infinitely.

Now when i select Run Installed OS from live usb options it just shows syslinux screen for a second and returns to the options. When I press tab to edit boot setting for installed os, it shows: .com32 boot/syslinux/chain.c32 hd0 0 when I change it to hd1 0 the grub loads and everything is fine.

But this is temporary..Every time I have to do this using live usb for getting grub. Why does this happen and what should i do to get grub permanently?

Note: The installation went fine and fdisk -l showed this error alone: partition 4 does not start at a physical boundary.

0

I'm not sure what the cause of the problem was exactly but I fixed it by booting from a windows 10 live disk and performing a startup repair. That solved the problem and now I get GRUB on booting the system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.