1

Currently I have a IP Camera, which allows the SSH access as root user.

The build-in Shell is BusyBox 1.19.3 (but guess not relevant to this issue). There are a few directories, such as /bin, /root, /dav, etc. It is this directory "/dav" is giving the issue of "Read-only File system", whenever I want to create a subdirectory, or create a file inside it.

I have tried some methods as suggested by others, such as: mount -o remount,rw /, however, it doesn't help in resolving the issue.

Does anyone have any solution to this issue? I will need to be able to write files in this "dav" directory.

Thank you!


here is what is seen with "mount": /dev/mtdblock5 on /dav type cramfs (ro,relatime)

  • If you want to remount /dav, then you want mount -o remount,rw /dav, not mount -o remount,rw /. – Tom Hunt Sep 2 '15 at 15:50
  • 1
    Tried, but not working. Here is what I found: /dev/mtdblock5 on /dav type cramfs (ro,relatime). Any clue? – greentealeaf Sep 4 '15 at 10:24
  • 2
    cramfs is by definition a read-only file system en.wikipedia.org/wiki/Cramfs it is, by the way, also obsolete. Replaced by squashfs. A different question that comes to my mind is... what is the motivation of it? what do you want to change inside your IP camera? – dave_alcarin Sep 4 '15 at 10:33
  • 1
    Thank you @dave_alcarin for pointing it out! The purpose is to make some changes on the language of the IP camera, by modifying some parameters. So with the cramfs which means read-only, does it mean there is no way to edit files in this directory? – greentealeaf Sep 4 '15 at 10:56
  • 1
    AFAIK no by these methods (remounting, I mean). You could always go further by tampering with the physical storage... but this of course is quite more dangerous! In the Wikipedia article that I linked a tool mkcramfs is mentioned. If you are able to cook your own cramfs image with the original cramfs from your camera plus your new parameters and store/flash it in the mtdblock5 of the IP camera, you would have effectively "written" by hacking the storage of your camera, basically. That's how most hacks in embedded systems are performed, by the way ;) – dave_alcarin Sep 4 '15 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.