So I have a dual boot setup using Windows 10 and Linux Mint 17.2 but I can't boot into Mint normally because my laptop always boots into windows without showing grub.

In order to boot into Mint I have to hold F12 while booting, select my HDD and then select 'ubuntu' or 'Ubuntu' from a list of items, which brings me to grub. From there I can boot into windows and mint.

How do I fix this? Using boot-repair didn't work and neither did reinstalling Windows or Linux.

2 Answers 2


use a live linux CD or DVD I suggest Ubuntu live and repair the grub or reinstall it.

mount the Mint partition to /mnt

and then:

sudo grub-install --root-directory=/mnt /dev/sda(the suitable based on your partition table) 

check it with the below command to find your Mint partition:

fdisk -l

and then :

  • First of all thank you for the fast response. ok I tried this and during sudo grub-install --root-directory=/mnt/dev/sda8 it gives me the following error: grub-probe: error: failed to get canonical path of '/cow'. Installing for i386-pc platform. grub-install.real: error: install device isn't specified. Sep 1, 2015 at 18:35
  • And if I mount the boot partition to /mnt I can see a folder named 'ubuntu' inside /mnt/dev/sda2/EFI. What if I delete it and install everything again? Sep 1, 2015 at 18:38
  • @NDTS for the grub-probe error try this one : mount --bind /proc /mnt/proc mount --bind /dev /mnt/dev mount --bind /sys /mnt/sys chroot /mnt grub-install /sd# yours seems 8 update-grub
    – FargolK
    Sep 1, 2015 at 19:38
  • OK so I fixed it by deleting the Ubuntu folder in /dev/sda2/EFI and then reinstalling grub with boot-repair from a live usb Sep 1, 2015 at 20:16

I'm not an expert, but I have observed that, if you don't turn off the fast boot feature of windows 10 before installing linux, these types of complications occur.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .