4

I am facing following situation.

  1. I am using arch linux

  2. I installed mutt the email client

  3. I followed the simple guidelines in the arch wiki to configure mutt to use imap

  4. For the simple config where no ssl is used, mutt tries to connect via username/password, after entering the password it says Logging in....Login failed without any error message

  5. So i tried to configure mutt to use ssl and ended up with this configuration

    set ssl_use_sslv3 = yes set spoolfile = imaps://username@domain.de:993 set folder = imaps://username@domain.de:993/INBOX set mail_check = 10

Which ends up with the following error:

SSL failed: error:14077102:SSL routines:SSL23_GET_SERVER_HELLO:unsupported protocol

On the other hand I am establish a connection via openssl to the imap server

openssl s_client -connect domain.de:993 -quiet

The endpoint server is a Lotus Domino if this matters.

So I am kind of clueless about those errors.

Update:

The link posted by @zelldon helped me in that way that setting ssl_use_sslv3 pushed me several steps forward. But now I got stuck at point 4 again -.-

  • 2
    What I'd do is to either 1) enable debug logging in mutt (mutt -d 2 ...) and find the reason for failing login from ~/.muttdebug0 (see man mutt for more info), or (if that fails since mutt was not compiled with debug logging) 2) revert mutt config back to non-SSL IMAP and use Wireshark to capture the dialogue between the server and the client and look for the server response to login. Or, if you have a nice Domino admin, maybe you could ask if there's something in the Domino log that reveals the reason for the error... – zagrimsan Sep 1 '15 at 13:32
1

Well it turned out that the username was incorrect. I was not supposed to use the email-address username but rather then I had to use my internal name instead. So this fixed the problem. Kind of embarrasing :D

  • It's good that you shared your experience. – Nikos Alexandris Feb 16 '16 at 19:46
1

I had the same error issue

SSL failed: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

but all the hints here didn't help me. For me, it was just to change the port to the right one:

False: set smtp_url = "smtps://user@gmail.com@imap.gmail.com:587/"

Right: set smtp_url = "smtps://user@gmail.com@smtp.gmail.com:465/"

Maybe it's the solution for someone else out there. Enjoy mutt!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.