1

On my Fedora (Fedora 22 Workstation) system, I recently installed Eclipse (sudo dnf install eclipse-platform). However, I am unable to launch Eclipse without using sudo. I would prefer not to have to use sudo to launch Eclipse. I have already tried reinstalling it .

Output if I use the command eclipse:

(Eclipse:2709): GLib-GObject-WARNING **: The property GtkMisc:ypad is deprecated and shouldn't be used anymore. It will be removed in a future version.

The above message does not show up if I use sudo eclipse.

I also tried gksu-polkit eclipse and got this output:

/usr/bin/xauth: file /home/<my_username>/.Xauthority does not exist /usr/bin/xauth: file /home/<my_username>/.Xauthority does not exist Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

In addition, when I run gksu-polkit eclipse, I get an Eclipse error window that says:

The Eclipse executable launcher was unable to find its companion shared library.

  • Can you show the results of ls -lat eclipseFilename? – ryekayo Sep 1 '15 at 1:56
  • lrwxrwxrwx. 1 root root 26 Aug 11 07:44 /bin/eclipse -> /usr/lib64/eclipse/eclipse – sameer-s Sep 1 '15 at 1:59
  • Can you change the ownership of the file to the appropriate user:group – ryekayo Sep 1 '15 at 2:00
  • Ok, I changed the ownership. Even after doing that, eclipse doesn't launch – sameer-s Sep 1 '15 at 2:03
  • Maybe root has a significant difference in $PATH? – Roflo Sep 1 '15 at 15:37
1

I finally got this to work (sort of).

I was running my Fedora machine on a GNOME Desktop Environment which was using the Wayland window system. When I switched to X, it ended up working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.