3

I have a fresh install of Arch Linux using Gnome 3 as my Desktop Environment. I also installed nvidia proprietary drivers for my GTX 970. The problem i'm facing is that after my log-in screen pops up and i enter my credentials, it takes about 40 seconds to reach my desktop and during this "down time" my monitor enters a power saving state. I get to my desktop and if i open up a terminal and run ps -e | grep -E "(gnome|gdm)", I get the following output

  313 ?        00:00:00 gdm
  434 ?        00:00:00 gdm-session-wor
  437 tty1     00:00:00 gdm-x-session
  454 tty1     00:00:00 gnome-session
  470 tty1     00:00:00 gnome-settings-
  490 tty1     00:00:01 gnome-shell
  639 ?        00:00:00 gdm-session-wor
  649 ?        00:00:00 gnome-keyring-d
  663 tty2     00:00:00 gdm-x-session
  670 tty2     00:00:00 gnome-session
  696 tty2     00:00:00 gnome-settings-
  742 tty2     00:00:12 gnome-shell
  756 tty2     00:00:00 gnome-shell-cal
 1165 tty2     00:00:00 gnome-terminal-
 1168 tty2     00:00:00 gnome-pty-helpe

From this output I get that somehow, gnome-session starts up on 2 different ttys. If I switch to tty1, Same story as with logging in. My monitor goes to power saving, I wait aprox 40 seconds and then I get the login screen.

I have no idea where to start looking for the problem.

I installed gnome using pacman -S gnome, chose the mesa-libgl library and after i got to the desktop environment, i downloaded nvidia proprietary drivers, blacklisted nouveau and ran the .run nvidia file.

Has anyone encountered this situation? Do you have any idea what can I do? which log fiels should I open up or configs to change?

Thanks

  • you might try display mangers other than gdm ? (I think after you install another display manager you have to disable gdm.service and enable whatever display manager you installed) – niceman Sep 3 '15 at 15:50
1

I don't have the solution. However, I have the same issue with Arch Linux and it is a known gdm bug, see GNOME Bugzilla – Bug 747339. https://bugzilla.gnome.org/show_bug.cgi?id=747339

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.