After reinstalling the server I can not mount it:

sshfs [email protected]:/var /remote_mount
fuse: bad mount point `/remote_mount': Transport endpoint is not connected

When I SSH, I get an error:

# ssh [email protected]
The authenticity of host 'example.com (xxx.xxx.xxx.xxx)' can't be established.
ECDSA key fingerprint is 57:b6:bd:76:17:80:73:85:4a:14:8a:6f:dc:fa:fe:7c.
Are you sure you want to continue connecting (yes/no)?
  • Post output of ssh -v [email protected]?
    – BAR
    Aug 31, 2015 at 8:58
  • question updated..
    – clarkk
    Aug 31, 2015 at 9:03
  • Type yes and try again.
    – BAR
    Aug 31, 2015 at 9:04
  • @BAR, after I did ssh [email protected] I deleted the old RSA key and now it works again.. (The server got a new IP address) Create an answer :)
    – clarkk
    Aug 31, 2015 at 9:20
  • Good to know it worked for you!
    – BAR
    Aug 31, 2015 at 9:21

2 Answers 2


This error popped up for me after I had been using sshfs on and off for years. A search found this page but all the "setup sshd" answers were not much help as sshfs had been working well until it suddenly didn't and ssh worked just fine to other locations.

However, after a bit of frustrating poking and testing I found the solution. The problem started with a sshfs mount failing from a bad hostname in it. As ls -l $mountpoint failed with this error I tried clearing the trouble with fusermount -u $mountpoint, and the mount started to work again!

Even a simple ls $mountpoint made the error after the failed sshfs.

  • 1
    That was the problem here too. Jan 18, 2017 at 22:04
  • 2
    This helped.. but first I had to kill a process that had the mount point open lsof | grep $mountpoint
    – jsj
    Nov 13, 2017 at 0:08
  • @jsj that can be a good point.
    – Gilbert
    Nov 19, 2017 at 0:39

I had this problem after using sshfs for some time. This answer is relevant only for situations where sshfs was already used successfully prior to the problem.

What usually causes this problem is that you terminated the connection sometime ago, and the system still has the /remote_mount mounted. First try doing:

sudo umount /remote_mount

and then attempt to connect again.

  • 3
    Why was this downvoted? That made it for me, thank U !!
    – Campa
    Feb 20, 2018 at 11:47
  • This answer was the right one for me too
    – CharlesB
    Mar 30, 2018 at 8:05
  • This makes sense and worked for me, I got the same error when clicking the mounted directory in Nautilus "Files" Browser. I ran the umount command and it reset the state so it could be mounted again! Oct 29, 2019 at 21:30
  • Great answer. Thanks ! Jan 6, 2020 at 14:03
  • This is resonable and correct i think
    – munish
    May 28, 2020 at 11:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .