14

After reinstalling the server I can not mount it

sshfs root@domain.com:/var /remote_mount
fuse: bad mount point `/remote_mount': Transport endpoint is not connected

update

# ssh root@domain.com
The authenticity of host 'domain.com (xxx.xxx.xxx.xxx)' can't be established.
ECDSA key fingerprint is 57:b6:bd:76:17:80:73:85:4a:14:8a:6f:dc:fa:fe:7c.
Are you sure you want to continue connecting (yes/no)?
  • Post output of ssh -v root@domain.com? – BAR Aug 31 '15 at 8:58
  • question updated.. – clarkk Aug 31 '15 at 9:03
  • Type yes and try again. – BAR Aug 31 '15 at 9:04
  • @BAR, after I did ssh root@domain.com I deleted the old RSA key and now it works again.. (The server got a new IP address) Create an answer :) – clarkk Aug 31 '15 at 9:20
  • Good to know it worked for you! – BAR Aug 31 '15 at 9:21
1

Your SSHd has not been setup.

Do that first and try again.

  • What do you mean? It has been installed on the server with apt-get install sshfs – clarkk Aug 31 '15 at 9:13
  • @clarkk sshd is totally different. This is your ssh daemon, your ssh server. The machine you are ssh-ing to needs to have sshd properly configured. Only then will sshfs work properly. Were you able to connect using ssh root@domain.com? – BAR Aug 31 '15 at 9:14
  • Ohh.. Didn't notice it was you who answered the question.. but it worked after I did ssh root@domain.com and it gave me an warning about DNS.. Then I deleted the old RSA key in the cache... and now it works.. The server got a new IP address – clarkk Aug 31 '15 at 9:22
34

After using sshfs on and off for years just got this error for the first time and found this page. All the "setup sshd" wasn't much of a help as ssh had been working.

However, a bit of testing found the solution. The problem occurred after a failed sshfs mount request with a bad hostname in it. As ls -l $mountpoint failed with this error I tried clearing the trouble with fusermount -u $mountpoint, and it worked!

After the failure I got the error on a simple ls $mountpoint after the failed ssshf.

  • That was the problem here too. – Dan Dascalescu Jan 18 '17 at 22:04
  • 2
    This helped.. but first I had to kill a process that had the mount point open lsof | grep $mountpoint – jsj Nov 13 '17 at 0:08
  • @jsj that can be a good point. – Gilbert Nov 19 '17 at 0:39
16

I had this problem after using sshfs for some time. This answer is relevant only for situations where sshfs was already used successfully prior to the problem.

What usually causes this problem is that you terminated the connection sometime ago, and the system still has the /remote_mount mounted. First try doing:

sudo umount /remote_mount

and then attempt to connect again.

  • Why was this downvoted? That made it for me, thank U !! – Campa Feb 20 '18 at 11:47
  • This answer was the right one for me too – CharlesB Mar 30 '18 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.