2

I used:

gsettings set org.gnome.desktop.wm.keybindings switch-applications "[]"
gsettings set org.gnome.desktop.wm.keybindings close "[]"

to disable Alt+Tab and to disable Alt+F4 respectively.

In Ubuntu 14.04: Alt+F4 worked, Alt+Tab failed (meaning the gsettings succeeded but the short-cut is still active)

In Debian 8: Both Alt+F4 and Alt+Tab failed

How can I solve this problem? (Or is there another way to disable short-cuts through the command line?)

1

You used the same key binding to try to do different things: the correct ones are:

gsettings set org.gnome.desktop.wm.keybindings switch-applications "[]"
gsettings set org.gnome.desktop.wm.keybindings close "[]"

If you did that already, try setting then to something ridiculously complex like ['Above_Tab'] that you will never type by accident, as your goal is to not type it accidentally...

  • As you're a reputation 1 user: If this answer helped you, don't forget to click the grey at the left of this text, which means Yes, this answer is valid! ;-) – Fabby Aug 30 '15 at 16:31
  • Sorry about spelling error, gsettings set org.gnome.desktop.wm.keybindings close "[]" is the command i used. But there is no effect. – waitianlou Aug 31 '15 at 1:04
  • Have you tried setting them to something ridiculously complex like ['<Ctrl><Alt><Shift><Super>Above_Tab'] that you will never type by accident? (If your goal is to never type it by accident. If not: What is your goal?) – Fabby Aug 31 '15 at 6:43
  • Hello? You were here on Sept 2... Could you clarify? – Fabby Sep 5 '15 at 9:44
  • Favour returned... – Fabby Sep 6 '15 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.