1

See the following image:

image with Tamil characters

As you can see, the "ä" in the word "häufigkeit" is rendered with a Tamil glyph. This happens with almost all non-ASCII characters. For example, in the tab bar, after the title, there must be an ellipsis. Instead it is rendered with another Tamil glyph.

But this is not it. See the following image:

image with proper Unicode characters

In the word highlighted with orange color, see that "ä" is properly rendered.

I don't seem to observe any pattern in the appearance of Tamil characters. In most cases, it seems to be the case that in a editable text, proper characters appear an in a HTML rendered text, Tamil characters appear. For example, as I type the question, all the non-ASCII characters in the question I typed appear properly but in the question preview, Tamil characters pop up again. This is not a strict rule, as in the above image, orange word is not a part of text editable block and is still rendered properly.

Also, this seems to be a problem with internet related applications. Emacs usually renders all the characters perfectly. But when I open this site in EWW, Tamil characters pop up again in place of non-ASCII characters.

I tried to remove Tamil fonts to see what happens but there is no improvement. These characters are still rendered. I don't know where it (the renderer) gets them from.

Output of fc-list | grep Tamil, fc-list | grep tamil, fc-list | grep indic are all empty.

Any ideas that may explain this behaviour?

UPDATES:

C-u C-x = on the ä character in EWW gives the following result

Info on culprit character in EWW

(I could not copy paste the info here because then the Tamil character is rendered as normal latin character in here).

If I copy characters that are not properly rendered from Firefox or EWW to normal Emacs text file, they are rendered properly. This is how I've been surviving :)

I've been observing this problem also on HTTPS sites. For example this site on Wikipedia is not rendered properly.

One more interesting thing is that I create a file new with some non-ASCII characters. Emacs renders the file properly but Firefox displays the characters ä. Output of file new:

new: UTF-8 Unicode text, with no line terminators
  • Point of data on what it's probably not: linguee.com sends encoding as iso-8859-15, duden as utf-8. (I briefly suspected that what you see is the one-byte 8859-15 character ä being converted into the two-byte utf-8 sequence for ä, and that two-byte sequence erroneously treated as two 8859-15 characters and being translated into a four-byte sequence of two utf-8 characters that happen to be combining characters.) – Ulrich Schwarz Aug 30 '15 at 8:07
  • But it wouldn't explain why ellipsis in tab bar are rendered wrongly. If it would please write it as an answer and also add any remedy you know of. – nitishch Aug 30 '15 at 8:19
  • @UlrichSchwarz That sequence wouldn't lead to any Tamil characters. äää (where the second character is U+0083, a control character which your browser probably doesn't render as a glyph). – Gilles 'SO- stop being evil' Aug 30 '15 at 23:16
  • In EWW, what does C-u C-x = say about that character? Do you observe the problem with any HTTPS site? With local files? If you copy-paste into some other application, what character do you get? – Gilles 'SO- stop being evil' Aug 30 '15 at 23:18
  • @Gilles please see the question update – nitishch Aug 31 '15 at 4:49
1

As @Gilles points out in the comments, it is a font issue. I tried C-u C-x = on the wrongly rendered character and on the ä character that is rendered properly.

The only difference was on this line:

For properly rendered character:

xft:-paratype-PT Mono-normal-normal-normal-*-17-*-*-*-m-0-iso10646-1 (#xA5)

For wrongly rendered character:

See the last line of 3rd image in the question.

As one can see, for some reason, Emacs and Firefox use TSCU_Paranar font which happens to be a Tamil font. I removed this font and changed the default font in both of them to one which supports all Latin characters.

This solved the problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.