4

I'm trying to configure sox to use a webcam that I just ordered. I've confirmed that the mic works through the GUI.

I ran arecord -l and found that the card, device numbers are 1 and 0, respectively.

I'm using sox through a Node.js library that runs it with the following arguments:

this.cmdArgs = [
    '-q',
    '-b','16',
    '-d','-t','flac','-',
    'rate','16000','channels','1',
    'silence','1','0.1', '0.1%','1','1.0', '0.1%'
];

However, I all I hear from the mic is really loud static.

I've tried setting AUDIODEV to hw:1,0 and AUDIODRIVER to alsa but I have the same issue. Any ideas?

  • 1
    You may have the right device, but the wrong format, so that the audio bits are getting scrambled. If so, you'd probably be able to hear changes in the "static" with changes in the audio input. – Daniel Griscom Mar 19 '16 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.