1

I am running Linux Mint on my Laptop (MacBook Pro 2015 dual booting with Yosemite) however when I put my lid down I have the setting set to 'Hibernate'. The issue is when I put the lid down I cannot seem to wake the computer up again, all I get is a blank screen. I have tried to click the trackpad and type random letters on the keyboard (even tried the power button) but nothing works. The only response I get when I wake the computer up is a 'click' from the ForceTouch trackpad when I press on it.

Would I need to install some drivers or something to prevent this issue? If so what do I do to install it. If not what are the steps required to prevent the 'black screen of death' when waking my computer up from hibernation mode.




Here are my Error Logs:

kern.log
pm-powersave
pm-suspend.log
syslog

migrated from superuser.com Aug 28 '15 at 16:42

This question came from our site for computer enthusiasts and power users.

  • Have you got a swap partition? If not you won't be able to hibernate, but sleep mode should work. – AFH Aug 23 '15 at 15:51
  • I do. I think. When I partitioned it I made a swap and root partition. Is there a way to check I have it enabled? I have 16GB ram and made a 16GB swap partition. It does show up as 15.4GB. Could that be why? Sleep also had the same affect I think. Will recheck soon. – iProgram Aug 23 '15 at 15:56
  • The simplest check is to run free -h. The final line should be something like Swap: 18G 329M 18G (my current report). Alternatively swapon should report something like /dev/sda7 partition 18.6G 329.1M -1. – AFH Aug 23 '15 at 16:03
  • 1
    That seems OK. I use Ubuntu, also a Debian derivative, and I assumed that it would use the same swapon, wrongly as it seems. – AFH Aug 23 '15 at 16:21
  • 1
    I don't have a lot to go on: see if the system logs reveal anything. You could try hibernating without closing the lid, which may cause undesirable side-effects on the hardware which recovery from hibernation doesn't handle; or see if you can get sleep mode to work: this will still put a small drain on the battery (unlike hibernation), but that would be preferable to crashing. – AFH Aug 23 '15 at 16:48
1

A workaround for the problem is to disable any action which is triggered by closing the lid. This can usually be set in the power options in your system settings interface. You also need to make sure that the display automatically dims while idle, and that the computer does not auto-suspend after a certain period of time.

On modern computers (especially with ULV CPU) with low power consumption leaving the computer on does not take a lot of power at all. Therefore you should be OK with this. Exceptions are only a few websites (open web pages which make JavaScript or other computations without user interaction), you can try this out by running the command top in a terminal window (on newer systems top -o %CPU gives you better visibility of CPU-hungry processes). There you can see whether a process like firefox is hogging a lot of CPU (like 50%) or the computer it is idling (no process over 10% or so).

This worked for myself on a similar machine, avoiding the crashes when suspend was tried and failed.

  • Thanks for the answer. I have only up-voted this and not marked it as answered since I want to see if other people can find a solution. If I don't get a solution within a week I shall accept this. – iProgram Aug 29 '15 at 9:01
  • 1
    Thanks, you are quite right. Hope someone finds a true answer! – Ned64 Aug 29 '15 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.