7

I am trying to install the build dependencies for Wine, so that I can do a bit of hacking with it. I am running Fedora 22, 64-bit.

I have installed the 64-bit dependencies successfully using dnf builddep:

# dnf --version
1.1.0

# dnf list wine
Available Packages
wine.i686                                                           1.7.47-1.fc22                                                         updates
wine.src                                                            1.7.47-1.fc22                                                         updates-source
wine.x86_64                                                         1.7.47-1.fc22                                                         updates

# dnf builddep wine
Package ImageMagick-devel-6.8.8.10-9.fc22.x86_64 is already installed, skipping.
Package alsa-lib-devel-1.0.29-1.fc22.x86_64 is already installed, skipping.
Package audiofile-devel-1:0.3.6-6.fc22.x86_64 is already installed, skipping.
Package autoconf-2.69-20.fc22.noarch is already installed, skipping.
...

And now my problem - I want to also install the 32-bit dependencies, but cannot get it to work. Here are the things I have tried:

# dnf builddep wine.i386
no package matched: wine.i386
Error: Some packages could not be found.

# dnf builddep wine.i686
no package matched: wine.i686
Error: Some packages could not be found.

# dnf builddep wine-1.7.47-1.fc22.i686
no package matched: wine-1.7.47-1.fc22.i686
Error: Some packages could not be found.

# dnf builddep wine --target=i686
Error: unrecognized arguments: --target=i686

I have even tried some deprecated yum commands:

# yum-builddep wine --target=i386
# yum-builddep wine --target=i686
# yum-builddep wine-1.7.47-1.fc22.i686

The above result in:

 --> Already installed : zlib-devel-1.2.8-7.fc22.x86_64
 --> Already installed : unixODBC-devel-2.3.2-6.fc22.x86_64
 --> Already installed : sane-backends-devel-1.0.24-14.fc22.x86_64
...

How can I get dnf builddep to install the 32 bit dependencies for wine? The dnf command does not appear to support a --target option.

One obvious workaround is to get the list of packages individually and install them with dnf install; however, I am curious to know if dnf builddep can do it.

2
  • So has this ever been solved? Commented Oct 10, 2015 at 18:03
  • @David no, it hasn't been solved. I even tried to download the packages individually and had problems. If I recall correctly, dnf could not find some of the 32 bit binaries. The next step was to build those from source, but I never made it that far. I think I am going to wait for Fedora 23 and see if things improve.
    – chue x
    Commented Oct 10, 2015 at 19:10

1 Answer 1

1

Red Hat bugzilla suggests to use setarch i686 dnf builddep .... According to the listed output this seems to work as expected.

https://bugzilla.redhat.com/show_bug.cgi?id=1312633

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .