My question is similar to this one, but has a few differences. At boot, I get the following message:

[    0.030164] Ignoring BGRT: invalid status 0 (expected 1)
:: running early hook [udev]
starting version 223
:: running hook [udev]
:: Triggering uevents...
:: performing fsck on '/dev/sda8'
sda8: clean, ...
:: mounting '/dev/sda8' on real root
:: running late hook [usr]
:: performing fsck on '/dev/sda5'
sda5: clean, ...
:: mounting /dev/sda5 on /usr
:: running cleanup hook [shutdown]
:: running cleanup hook [udev]
ERROR: Root device mounted successfully, but /sbin/e4rat-preload does not exist.
Bailing out, you are on your own. Good luck.

sh: can't access tty; job control turned off
[rootfs /]#

(It says the same thing if I tell GRUB to use /sbin/init or /bin/systemd.)

As suggested by the accepted answer in the other question, I chroot'd into the Arch install using a live-CD, added the correct hooks to mkinitcpio.conf, marked /usr with a passno of 0 in /etc/fstab, and recreated the init image using mkinitcpio -p linux-ck.

It seems to have worked, but the result is still the same and I am now unable to chroot into the system.

$ arch-chroot /mnt
chroot: failed to run command `/bin/bash': No such file or directory

sudo parted -l:

sudo parted -l /dev/sda
Model: ATA Hitachi HTS54757 (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  1075MB  1074MB  fat32        EFI System Partition          boot, esp
 2      1075MB  270GB   268GB   ntfs         Windows 10                    msftdata
 3      270GB   484GB   215GB   ntfs         Jeffrey                       msftdata
 4      484GB   484GB   16.8MB               Microsoft reserved partition  msftres
 5      535GB   589GB   53.7GB  ext4
 6      589GB   643GB   53.7GB  ext4
 7      643GB   696GB   53.7GB  ext4
 8      696GB   750GB   53.7GB  ext4         Arch


# /dev/sda5
PARTUUID="4495844c-bbf3-4be0-a2f3-7d143077a2ed"        /usr                  ext4          ro,relatime                                                                                      0 2

# /dev/sda6
PARTUUID="23a5589e-5e88-40a3-9497-d3da166f3d4a"        /tmp                  ext4          rw,relatime,noexec,nosuid                                                                        0 0

# /dev/sda7
PARTUUID="07a6f06a-87f2-405e-a3d7-d26c5085041e"        /mnt/bindir           ext4          rw,relatime,nosuid                                                                               0 2

/mnt/bindir/root                                       /root                 none          bind                                                                                             0 0
/mnt/bindir/var                                        /var                  none          bind                                                                                             0 0
/var/home                                              /home                 none          bind                                                                                             0 0
/tmp                                                   /var/tmp              none          bind                                                                                             0 0

# /dev/sda1
PARTUUID="e532f9e3-ccd5-4edf-a8b0-35069e8afb35"        /boot                 vfat          rw,relatime,umask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro        0 0

# /dev/sda2
PARTUUID="f373613c-9b70-42c1-8266-d5774b212ef"         /mnt/Windows          ntfs-3g       rw,relatime,errors=remount-ro,users,nosuid,nodev,nofail,x-gvfs-show                              0 0

# /dev/sda3
PARTUUID="e8fd05ac-9496-40fb-af01-01b41958fd41"        /mnt/Jeffrey          ntfs-3g       rw,relatime,errors=remount-ro,users,nosuid,nodev,nofail,x-gvfs-show                              0 0
                             0 0

2 Answers 2


I see:

mounting '/dev/sda8' on real root

Shouldn't you have an entry in your fstab for /dev/sd8 for the / directory. I see all your other mount points other than your actual root.

  • I had it commented out. Adding it in does nothing.
    – user20282
    Aug 28, 2015 at 17:59
  • At the prompt can you access /bin/bash before the arch-chroot?
    – Will
    Aug 28, 2015 at 18:04
  • I can access /usr/bin/bash but not /mnt/usr/bin/bash, sh, zsh. I can access fish, but fail to run command /usr/bin/fish in chroot.
    – user20282
    Aug 28, 2015 at 18:18
  • The entry for / in /etc/fstab is not directly relevant. It isn't used to mount the root partition at boot time — the root partition has to be mounted before the file can be read. The entry for / can be used to set different mount options. It might influence the automatic generation of the bootloader configuration or of an initrd/initramfs; I don't know if it does on Arch. Aug 28, 2015 at 23:22
  • @Gilles I believe that / is first mounted, and is later remounted with the proper options sometime during the boot process.
    – user20282
    Aug 28, 2015 at 23:43

When I ran ldd /mnt/usr/bin/bash, I noticed that some required libraries were missing. I copied the contents of /usr/lib in the live CD to /usr/lib on my computer. Now I was able to chroot into my installation.

I downloaded the snapshot of Linux-ck from the AUR, edited the .config to suit my needs, and compiled the kernel. Then, I ran mkinitcpio -p linux-ck and grub-mkconfig -o /boot/grub/grub.cfg.

Afterwards, I was able to boot into a partially working system. It seems like I was missing some packages, and the packages that were installed had missing files, determined with pacman -Qk. I tried to reinstall all packages with pacman -Qenq | pacman -S -, but that didn't work because pacman's database was corrupt. I had to restore the local database, which also solved the previous problem.

At present, the only thing that still doesn't work is GNOME.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy