3

Console Output:

bitnami@linux:~$ sudo svnmucc propset svn:needs-lock 1 file:///opt/bitnami/repositories/Standard/Ipc/trunk -m "test set"
svnmucc: error while loading shared libraries: libsvn_client-1.so.0: cannot open shared object file: No such file or directory
bitnami@linux:~$ ldd /opt/bitnami/subversion/bin/svnmucc
        linux-vdso.so.1 =>  (0x00007ffee8dfc000)
        libsvn_client-1.so.0 => /opt/bitnami/subversion/lib/libsvn_client-1.so.0 (0x00007f3d66102000)
        libsvn_wc-1.so.0 => /opt/bitnami/subversion/lib/libsvn_wc-1.so.0 (0x00007f3d65e30000)
        libsvn_ra-1.so.0 => /opt/bitnami/subversion/lib/libsvn_ra-1.so.0 (0x00007f3d65c22000)
        libsvn_diff-1.so.0 => /opt/bitnami/subversion/lib/libsvn_diff-1.so.0 (0x00007f3d65a09000)

I tried:

"No such file or directory" on an executable, yet file exists and ldd reports all libraries present

I installed:

lib32z1, lib32ncurses5, lib32bz2-1.0

I set:

LD_LIBRARY_PATH="/opt/bitnami/subversion/lib:/opt/bitnami/sqlite/lib:/opt/bitnami/apache2/lib:/opt/bitnami/common/lib"

I am on a -

linux 3.13.0-55-generic #94-Ubuntu x86_64 GNU/Linux

- Bitnami SVN stack. So it is very likely that the Bitnami guys might have cranked something up. Fresh Debian/Arch/Ubuntu is not a solution (Company doesn't want something they can't pay for)

Q: How do I get further? It should have a 64bit 'lib-loader' installed since I am on a 64bit System. svnmucc is further provided by SVN itself, so it should have all libs necessary installed. I would figure that Bitnami somewhat tempered with the System, and now it doesn't have access to it (or something similar). Yet I haven't dealt much with libraries, which is why I am not very well funded in that topic.

  • Welcome to Unix&Linux SE! Take a tour to get familiar with our philosophy, and edit your question to provide more information, as well as better formatting. Your console output should be posted in text format on this site. If you want to post image, I'd suggest posting it on site SE suggests. Also, rephrase your question - "What do" is not clear about what you are trying to achieve. – MatthewRock Aug 28 '15 at 11:51
  • Is it fine like this? Negative response is better than no response. – tornado Aug 28 '15 at 12:25
  • Could you try after doing: export LD_LIBRARY_PATH=/opt/bitnami/subversion/lib ? Is it working after that ? – perror Aug 28 '15 at 12:26
  • i already set LD_LIBRARY_PATH=LD_LIBRARY_PATH="/opt/bitnami/subversion/lib:/opt/bitnami/sqlite/lib:/opt/bitnami/apache2/lib:/opt/bitnami/common/lib". But good point, i'll add it to the Question. – tornado Aug 28 '15 at 12:30
  • 1
    sudo tends to clear various environment variables to prevent e.g. some naughty user from loading in a malicious library and then hey presto full superuser access. Are you sure sudo isn't wiping LD_LIBRARY_PATH ? – thrig Aug 28 '15 at 14:36
6

LD_LIBRARY_PATH settings are dropped by sudo for the security. To avoid being affected by that, you could add those paths to dynamic loader's global search path list.

Put the library path lines in /etc/ld.so.conf.d/bitnami.conf:

/opt/bitnami/common/lib
/opt/bitnami/apache2/lib
/opt/bitnami/sqlite/lib
/opt/bitnami/subversion/lib

Then update /etc/ld.so.cache by the folowing command:

sudo ldconfig

See ld.so and ldconfig manuals for details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.