0

I want to sync my Google Calendar with the Linux Mint 17.2 desktop; preferably through Conky. I'm aware of a method using Thunderbird but I'd rather have it set up as described here. Following the steps, however, I encounter a number of errors (such as ImportError: No module named _MozillaCookieJar among others) and I couldn't manage doing the steps right. Comments in the link update some of the outdated steps but it seems some info is still missing. I tried looking for more updated links and came across this, but again seems the steps don't work properly. Can anyone point out exactly what to do (baby steps please)?

Details: When I do the first step from the first link, I try sudo pip install google-api-python-client and I get the ImportError: No module named _MozillaCookieJar error. When I tried the second link, I got to the step where it says pip install vobject parsedatetime and even after updating parsedatetime I still get the same ImportError: No module named _MozillaCookieJar error after trying pip install vobject parsedatetime a second time after updating. Maybe it's something wrong with pip?

Either way, I broke this question down into "Main Question" and "Details" because I think even if the "details" are fixed, I'll run into another bad step eventually and so if there is an easier way of going about this, please let me know.

  • What versions of python/pip are you running? – Jesse K Aug 27 '15 at 16:30
  • @JesseKeilson it says I'm using Python 2.7.6, not sure how to check what version pip is (when I tried sudo apt-get install pip it said it was unable to locate the package) – FearfulAnon Aug 27 '15 at 16:33
  • I'm asking because of this thread: stackoverflow.com/questions/9857677/… Looks like there were some name changes in some of the dependencies. You'll probably want to try installing python3 sudo yum install python3 and then for pip, try apt-cache search pip to figure out the right package name, though I'm pretty sure it's python-pip. – Jesse K Aug 27 '15 at 16:44
  • @JesseKeilson I think gcalcli says it won't work with python3; I used apt-cache search pip and you're right, it's python-pip but that's already installed apparently so I don't think that's the problem either. – FearfulAnon Aug 27 '15 at 16:53
  • Right you are! Let me read a little closer before I make more comments that don't apply. – Jesse K Aug 27 '15 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.