1

I am trying to install fail2ban on my centos 7.1 server

I did:

 yum install epel-release
    yum install fail2ban

But i am getting some error messages:

 yum install epel-release
    Package epel-release-7-5.noarch already installed and latest version
    Nothing to do

-----

[root@elliot ~]# yum install fail2ban
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * atomic: mirror1.34sp.com
 * base: centos.mirror.transip.nl
 * epel: ftp.nluug.nl
 * extras: centos.mirror.transip.nl
 * updates: centos.mirror.transip.nl
Resolving Dependencies
--> Running transaction check
---> Package fail2ban.noarch 0:0.9.2-1.el6 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: fail2ban-0.9.2-1.el6.noarch
--> Processing Dependency: python-inotify for package: fail2ban-0.9.2-1.el6.noarch
--> Processing Dependency: gamin-python for package: fail2ban-0.9.2-1.el6.noarch
--> Running transaction check
---> Package fail2ban.noarch 0:0.9.2-1.el6 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: fail2ban-0.9.2-1.el6.noarch
---> Package gamin-python.x86_64 0:0.1.10-16.el7 will be installed
--> Processing Dependency: gamin = 0.1.10-16.el7 for package: gamin-python-0.1.10-16.el7.x86_64
--> Processing Dependency: libgamin-1.so.0()(64bit) for package: gamin-python-0.1.10-16.el7.x86_64
---> Package python-inotify.noarch 0:0.9.4-4.el7 will be installed
--> Running transaction check
---> Package fail2ban.noarch 0:0.9.2-1.el6 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: fail2ban-0.9.2-1.el6.noarch
---> Package gamin.x86_64 0:0.1.10-16.el7 will be installed
--> Finished Dependency Resolution
Error: Package: fail2ban-0.9.2-1.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-18.el7_1.1.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python-2.7.5-16.el7.x86_64 (base)
               python(abi) = 2.7
               python(abi) = 2.7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@elliot ~]# 

Can someone help me to fix this problem? I also tried to install it on a new server, and I had no problem on that server

P.S if you want you can login in to my PC

  • What does "rpm -q epel-release" say? – John Aug 27 '15 at 12:29
1

It looks like you might have two epel-release packages installed - one for EPEL 6, one for EPEL 7. Your first yum command shows epel-release-7-5 is installed, your second yum command is pulling in fail2ban-0.9.2-1.el6 which is from EPEL 6 (not 7). If this is the case, you should see two results from rpm -q epel-release. If you then yum remove the EPEL 6 release package and issue a yum clean all, you should then be able to yum install fail2ban successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.