1

I have been using GNU/Linux for several years and now I am giving FreeBSD a try.

Yesterday I managed to install FreeBSD 10.2 on an old computer using a 5 GB partition. I only installed the base system and a few programs and everything seems to work fine. The disk on which I installed FreeBSD contains another primary partition which is used by GNU/Linux.

Today I wanted to try installing FreeBSD on a 43 GB spare disk on another computer. The disk has three primary (empty) partitions already. Using fdisk under GNU/Linux I set the type of one partition to a5 (FreeBSD): I wanted to install FreeBSD on this partition / slice. I then booted the FreeBSD installation CD and expected I would only need to create labels inside the FreeBSD slice, but the FreeBSD fdisk that is started by the installer won't see any partition at all! It reports the whole disk as unused and offers to create a new slice.

For me it is OK to use the whole disk, but why doesn't fdisk see the existing slices? Note that on the older computer I was able to see and use a 5 GB partition using the same installation CD.

Am I overlooking something?

EDIT

I found out there are problems when trying to access the two disks from FreeBSD. After booting the installation CD I opened a shell. I looked for my two disks. If I understood correctly, they are

/dev/ad0           # Blank 43 GB disk where I want to install FreeBSD
/dev/ad2           # 60 GB disk with working Debian 8 on it

When I try to access both disks from the shell with

# diskinfo -c ad0
# diskinfo -c ad2

I get error messages:

(ada1:ata1:0:0:0) READ_DMA. ACB: c8 00 00 00 00 40 00 00 00 01 00
(ada1:ata1:0:0:0) CAM status: ATA Status Error
(ada1:ata1:0:0:0) ATA status: 51 (DRDY SERV ERR), error: 84 (ICRC ABRT )
(ada1:ata1:0:0:0) RES: 51 84 00 00 00 00 00 00 00 00 00
(ada1:ata1:0:0:0) Error 5, Retries exhausted
diskinfo: read: Input/output error

Note that I get the same error on both disks while I can access both disks from Debian. The only thing I can think of is that I need to change some BIOS setting, but I have no idea what the problem could be.

EDIT 2

Booting with

hw.ata.ata_dma=0

seems to solve the problem. I got the hint from here. Still, I am not sure what the problem is and why setting this variable would solve it. IMO the problem should not be caused by a bad drive because at least one of the disks has no errors (checked it recently for bad blocks). I will check the other disk now.

0

The "geom disk list" command will show you which disk is which. The problem in dmesg looks like a disk problem, but if the hw.ata.ata_dma=0 workaround worked, then it's probably something between the driver and the controller.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.