2

I'm trying to get 'clipboard' perl extension for urxvt to work. I installed the script, it didn't work, and after some searching around I discovered that Cygwin's rxvt-unicode package is built with "--disable-perl" by default.

So I downloaded the source, changed it to "--enable-perl" and built/installed it. However, urxvt either stil doesn't seem to have perl extensions enabled when launched normally or the plugin 'clipboard' isn't being launched by default even though I've added

URxvt.perl-ext-common: default,matcher,clipboard to my .Xdefaults file.

Interestingly enough, the plugin works fine when I launch urxvt like this:

urxvt -pe clipboard

but I can't figure out if either perl extensions just aren't working from launch or the extension isn't working from launch, and why.

Here is the contents of my .Xdefaults file:

urxvt*font:             xft:gohufont:size=6
urxvt*boldFont:         xft:gohufont:size=6
urxvt*scrollBar:        false
urxvt*matcher.button:   1
urxvt.transparent:    false
urxvt*allow_bold:    true
urxvt.internalBorder: 15

Xft*dpi:                96
Xft*antialias:          true
Xft*hinting:            full

URxvt*geometry: 90x20
URxvt*fading:        0
URxvt*tintColor:     #ffffff
URxvt*shading:        0
URxvt*inheritPixmap:     False

URxvt.iso14755: false

URxvt*perl-lib: "C:\cygwin64\lib\urxvt\perl"
URxvt*perl-ext-common:  default,clipboard
URxvt*keysym.M-c:   perl:clipboard:copy
URxvt*keysym.M-v:   perl:clipboard:paste
URxvt*keysym.M-C-v: perl:clipboard:paste_escaped

URxvt*cursorBlink:                  true
URxvt*cursorUnderline:              true
URxvt*cursorColor:                  #ffffff
URxvt*scrollColor:                  #151515

*foreground:                         white
*background:                         #141115

!black
*color0:                             #3f3671
*color8:                             #514692
!red
*color1:                             #b52f43
*color9:                             #df3a53
!green
*color2:                             #91a7a7
*color10:                            #906b61
!yellow
*color3:                             #6c7f97
*color11:                            #b3b7c3
!blue
*color4:                             #3e456f
*color12:                            #59639f
!magenta
*color5:                             #6d577c
*color13:                            #9e7eb4
!cyan
*color6:                             #729392
*color14:                            #92bdbb
!white
*color7:                             #a9ac97
*color15:                            #e6eace

closed as off-topic by Thomas Dickey, Jeff Schaller, sam, Archemar, Networker Jul 4 '16 at 9:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Thomas Dickey, Jeff Schaller, sam, Archemar, Networker
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Updating the file doesn't immediately make the changes active. Did you run xrdb -merge .Xdefaults? Alternatively, you could also restart your X server. At any rate, if it worked, xrdb -q should show you the options you asked for. – Wouter Verhelst Aug 25 '15 at 21:53
  • @wouter-verhelst Yes, I have run xrdb -merge .Xdefaults and I have tried restarting my X server (Xming, specifically). xrdb -q shows my options correctly however the plugin still does not work by default. But the plugin does work when I launch urxvt through urxvt -pe clipboard as I mentioned before, which is odd. – Darius Aug 25 '15 at 22:13
0

I've figured it out. I'm supposed to run export DISPLAY=:0 before running urxvt, which I wasn't able to do since I made my Cygwin.bat file run urxvt directly. That explains why the extensions "weren't working".

Not the answer you're looking for? Browse other questions tagged or ask your own question.