I am trying to dual boot Linux on my laptop (Dell XPS 15) which is running Windows 10 Pro. I did not have any problem dual booting the two operating systems on my desktop.

I cannot boot up ANY Linux Distro, I have tried Mint, Ubuntu and Elementary OS. Whenever I try to boot from a live USB, I get the this message on all attempts:

GNU GRUB version 2.02~beta2-9ubuntu1

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists are possible device or file completions.


When I type in "boot" I get the error: you need to load the kernel first.

Secure boot is disabled, and I have tried both in legacy and UEFI BIOS mode. I have never come across this error before, what causes it?

  • Did you tinker with legacy support for USB in BIOS? BTW please read the help→tour and leave out distractions and chit-chat in your posts, that will be appreciated by all future readers.
    – Anthon
    Commented Aug 25, 2015 at 10:14
  • @Anthon Thanks for the heads up. No I have not changed any USB settings in the BIOS. The only USB options in there are: USB Emulation, USB Powershare, USB Wake Support and USB debug.
    – Sylvoo
    Commented Aug 25, 2015 at 12:29
  • I would at least set USB emulation to on if it is not already set, I assumed that GRUB would use the BIOS to read the data from USB, but I am not 100% sure if it does (if not, some new USB chipset might be the problem).
    – Anthon
    Commented Aug 25, 2015 at 12:35
  • Your laptop has partly succeeded in its attempt to boot the live USB otherwise you wouldn't see the GRUB prompt. But GRUB hasn't been able to load the kernel so it can't go any further. Usually that sort of message happens when the kernel &/or other essential boot files aren't where GRUB expects them, or if the disk they're on is unreadable for some reason. My guess is that the system has "ejected" the USB after it's started to boot from it. You can see what partitions are available using the GRUB2 ls command (but I don't know the details since I use GRUB Legacy).
    – PM 2Ring
    Commented Aug 25, 2015 at 12:48
  • Another option that may be worth trying is to use a Live USB that uses a different bootloader, eg Grub4DOS or syslinux. Puppy Linux is a very compact distro (~130 MB) that uses syslinux by default. It's slightly non-standard so it doesn't play well with generic software that creates live USBs from bootable .iso file (like UNetbootin). But it's easy to create a live USB in a running Puppy system.
    – PM 2Ring
    Commented Aug 25, 2015 at 12:54

2 Answers 2


You say ANY distro fails... as such, the completeness of your question leaves much to be desired, until such time as you describe your preparation of this USB stick. Your point of being stuck half-way into Grub is familiar-- I was having success putting Mint on a thumbdrive via Unetbootin (though actually I had to find a tweak and edit the menu.lst file manually to get it to use the USB instead of looking for a CD, since I was using a .iso (CD) image source) but that stopped working when I tried Mint 18.x which apparently switched to syslinux from the simpler Grub in the 17.x with which I had had success. Searching a bit, I notice the Arch brainiacs seem to favour Gummiboot for UEFI environments: https://www.reddit.com/r/archlinux/comments/2l5rvk/syslinux_or_grub/

  • Please try to better format your answers. You should also avoid asking questions in an answer. That is usually done in comments. For the moment, since you don't have sufficient reputation to comment, you should stick to questions that can be answered directly. Commented Sep 7, 2016 at 2:29

i don't understand your situation now of your problem, but i think you are stuck in grub bootloader
so you can check how to boot from grub here

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review Commented Oct 8, 2021 at 22:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .