My environment consist of a Ubuntu 14.04 LTS VM. This is acting as the Xnest server on socket :2 and port 6002 (as seen by netstat). I'm running the Xnest as client on a Fedora 20 VM. The Ubuntu system runs Xnest 2:1:15:1. My Xnest version on Fedora is 1.14.4-14.fc20. When I try to remote connect from Fedora I can seem to connect but I get a black screen and not sure what I am doing wrong, if anything. I start the server on Ubuntu by running:

Xnest :2

From Fedora (the Client) I run:

Xnest -ac -query :2 -geometry 1024x768

And here is what I see in Fedora:

enter image description here

Any ideas as to what I may be doing wrong, or if this is possibly a bug?

1 Answer 1


The black screen can result from a number of things:

  • Nothing is running on that Xnest server - i.e. not even a window manager. For example, I also get a black screen when I just locally start Xnest :2. I have to explicitly start the window manager etc. via DISPLAY=:2 xfwm4 & etc.
  • The XDMCP client cannot connect to the necessary ports. For example, when I try to connect to a machine where I know that no X is running (e.g. via Xnest -query doesnothavexdmcp.example.org :2 -geometry 1024x768) I get a black screen as well. And no error message is displayed.
  • The Xnest server doesn't really have XDMCP enabled. XDMCP is considered a security risk and thus usually not enabled by default. If I start a Xnest :2 on e.g. Fedora it surely doesn't have XDMCP enabled.

To rule out connection issues you can try to disable packet filters (e.g. Fedora has one enabled by default) and look at the XDMCP traffic with wireshark.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .