1

I am trying to build GTK+ using JHBuild. I ran into the following error:

checking for GTK... no
configure: error: Package requirements (gtk+-3.0 >= 3.12 gtk+-x11-3.0 >= 3.12) were not met:

Requested 'gtk+-3.0 >= 3.12' but version of GTK+ is 3.10.8
Requested 'gtk+-x11-3.0 >= 3.12' but version of GTK+ is 3.10.8

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTK_CFLAGS
and GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
*** Error during phase configure of gcr: ########## Error running ./configure --prefix /home/xiaolong/jhbuild/releases/gnome-apps-3.17.90/install  --disable-static --disable-gtk-doc --disable-Werror  *** [15/29]

I am confused now. I want to build GTK+, so I need GTK+?! Why? Shouldn't that be independent from each other? How do I fix the issue?

The command I used to start the build process:

jhbuild -m ~/jhbuild/gnome-apps-3.17.90.modules build gtk+

(I had to tell jhbuild where it could find the modules, since I couldn't find any documentation about where the "modules directory" is supposed to be and no directory I tried to put the modules in worked - it never found them, if I didn't specify.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.